Jump to content
  • 0

filemaker serveur 10 : l'accès aux données d'un fichier lié ne se fait pas


ericire
 Share

Question

bonjour
j'exécute un script d'un fichier par un programme sur filemaker serveur 10.
Dans ce script je vais chercher des valeurs sur un fichier lié avec un droit de lecture.
Les comptes d'accès à l'un et l'autre des fichiers ont le même nom et le même mot de passe.
Il n'y a que les droits qui diffèrent, le premier étant administrateur.
Ce script exécuté en local fonctionne très bien : les valeurs du fichier lié sont bien captées,
mais depuis le programme du serveur, de nada, rien.

que je coche ou pas "exécuter le script avec les privilèges d'accès" ne change rien
dans le log serveur j'ai un "go te related Record" avec une erreur 100 (file is missing)
Une question de droits ou de source de données depuis le serveur ?

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Problème corrigé en 14.2, il y a 8 ans :)

De mémoire, si le fichier est préalablement ouvert explicitement par le script, alors ça fonctionne.

Link to comment
Share on other sites

  • 0

Bravo pour la mémoire !

il y a 33 minutes, fabriceN a dit :

si le fichier est préalablement ouvert explicitement par le script

La situation ne se présentera certainement jamais à moi, mais bon, ça signifie juste avoir un Ouvrir fichier en début de script, et hop ça marche ?

Link to comment
Share on other sites

  • 0

oui je crois mais le problème c'est l'authentification.

Ou alors peut être en exécutant un script de l'autre fichier. (ma mémoire a des limites, de plus en plus)

Link to comment
Share on other sites

  • 0

hello
résolu
j'ai agi sur les deux paramètres :
j'ai pu mettre le compte du fichier cible en accès intégral et j'ai modifié la source qui était en fmnet en file:nom fichier en local sur le serveur donc. Ainsi le script fonctionne uniquement sur le serveur et j'en ai fait un autre pour les clients.
merci ;)

Link to comment
Share on other sites

  • 0

ah ok. Le but dont je me souvenais était pour la première version de PSoS en 14.

Link to comment
Share on other sites

  • 0
Il y a 6 heures, fabriceN a dit :

Problème corrigé en 14.2, il y a 8 ans :)

De mémoire, si le fichier est préalablement ouvert explicitement par le script, alors ça fonctionne.

le pas de script "ouvrir fichier" n'est pas accessible en mode serveur sur FM10

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...