Jump to content
  • 0

Première expérience web


Matessias
 Share

Question

Bonjour à tous

Je teste mon application avec un hébergement gratuit et en essai : première expérience d'utilisation sur le web !

Aucun lien ne fonctionne !

Voici un exemple de modèle : normalement, en cliquant sur un enregistrement dans la TE à gauche, les infos s'affichent dans le "grand espace blanc" à droite !

Capture d’écran 2021-08-12 à 11.53.39.png

Link to comment
Share on other sites

Recommended Posts

  • 1
Il y a 7 heures, Matessias a dit :

normalement, en cliquant sur un enregistrement dans la TE à gauche, les infos s'affichent dans le "grand espace blanc" à droite

Salut Mamy,

Alors, si la technique est un bouton présent sur l'ensemble de la ligne de TE (chose que je fais beaucoup), sache qu'il y a une petite subtilité en WebDirect : le bouton doit être devant les rubriques contenues dans la TE. Si le bouton est derrière, les rubriques (même fermées en mode utilisation) empêchent l'accès au bouton.

A te lire,

Jérémie

Link to comment
Share on other sites

  • 1

Attention, les rubriques de la TE sont bien non accessibles en mode utilisation ?

Sinon, c'est du côté du script qu'il faudra chercher… Visiblement, ce script définit un rubrique globale, par laquelle on lie l'enregistrement qui doit apparaître sur le côté, c'est ça ? Si oui, y a-t-il un Rafraîchir fenêtre après la définition de la globale ?

Link to comment
Share on other sites

  • 0

Bonjour,

Le rafraichissement des fenêtres ne s'effectue pas de la même manière sur le web qu'en FileMaker.

Tu peux peut-être ajouter à l'action de sélection un rafraichissement de la fenêtre

Cordialement,

Tanguy

Link to comment
Share on other sites

  • 0

Ca marche, maintenant ?

De mémoire, ce point est l'un des plus marquants, quant aux différences de comportement entre FMP et WD. Il y en a d'autres, que tu découvriras au fur et à mesure…

Link to comment
Share on other sites

  • 0

Salut Jérémie

Ben non ! justement ! ça ne marche toujours pas !

Je sais pertinemment que c'est "juste" une question de détail, de pixel, de position ... bref ... de subtilité comme tu dis !

Je me mets au fourneau ... c'est en forgeant qu'on devient forgeron non ???

Link to comment
Share on other sites

  • 0

Les modèles carte ne fonctionnement pas non plus ! compréhensible !

Quelle belle remise en question !!!

Non !!! Je voulais dire popover !!!

Link to comment
Share on other sites

  • 0

Ah ! Si ! sur certains modèles, les popover fonctionnent !

Pareil pour le problème initial ! mais, il faut une précision chirurgicale pour que le cadre de sélection de l'enregistrement servant de bouton apparaisse !

Link to comment
Share on other sites

  • 0

Et pour être toujours positif, je dirai que c'est en étant en bonne santé qu'on peut prévenir et qu'on ne connait mieux la santé qu'après avoir été malade !

Bonne journée à toi aussi !

 

Link to comment
Share on other sites

  • 0

Juste un détail !

Qu'est-ce qui fait que la mise en forme conditionnelle ne marche pas pour certains éléments de la TE ?

Capture d’écran 2021-08-18 à 09.06.42.png

NB Je suis sur FM et non sur web !

Link to comment
Share on other sites

  • 0

Les formules de mise en forme conditionnelle sont-elles strictement les mêmes sur la colonne Processus et sur la colonne Situation ?

Peut-on les voir ?

Link to comment
Share on other sites

  • 0

Justement !

Ci-joint :

capture écran de la formule

- capture écran du même modèle avec une année et mois différents la formule fonctionne  

formule.png

mois.png

Link to comment
Share on other sites

  • 0

La première expérience web n'est qu'une série de "penalties" ratées !

J'ai parcouru les 30 pages sur WebDirect du forum et je résume que WebDirect n'est pas très sympa ... et un apprenti paie royalement les frais ... revoir complètement son application ! Un guide est le bienvenu "avant" et devient carence "après" !

Je trouve pourtant que c'est une solution plus qu'incontournable ; alors, une sortie de crise est plus que nécessaire !

Aux armes ! Forum-iens ! Formons nos bataillons !

penalty.jpg

Link to comment
Share on other sites

  • 0

Bonjour à tous

Lorsqu'un bouton placé sur une popover ne fonctionne pas sur web, l'application perd tout simplement sa raison d'être et n'a plus d'utilité !

etourdi.jpg

Link to comment
Share on other sites

  • 0
il y a 17 minutes, Matessias a dit :

Lorsqu'un bouton placé sur une popover ne fonctionne pas sur web

Salut Mamy,

Alors, tout bouton n'est pas censé devenir non utilisable dans un popover sur le Web… Quelles caractéristiques possède ce bouton ?

Link to comment
Share on other sites

  • 0

Jérémie

Dans la capture_1 : les deux boutons "Risques" et "Opportunités" ne fonctionnent pas ! C'est la base de tout !!!

Dans la capture_2 : le bouton "Afficher tout" est censé réinitialiser les deux boutons de recherche et afficher les enregistrements de la TE !

capture_1.jpg

capture_2.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...