Jump to content
  • 0
ikaa WHB

Récupérer la valeur d'une rubrique Filemaker sur une variable AppleScript

Question

Bonjour à tous,

Je cherche à récupérer le contenu d'une rubrique de ma base FileMaker dans une variable AppleScript, est-ce que cela est possible ?

Merci!

Cordialement,

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Bonjour,

Si les paramètres de sécurité sont bien activés dans "Fichier/Gérer…/Sécurité…/Paramètres avancés/Privilèges étendus/  ==> fmextscriptaccess (coché pour le/les compte(s) ciblés) …

exemple minimaliste

Définir variable [ $commande; Valeur :"set myAppleScriptVariable to " & Citation ( OccurrenceDeTable::NomDeLaRubrique ) & ¶ & 
"display dialog  myAppleScriptVariable with title \"My Custom Window Title\" buttons \"OK\" default button 1 with icon 0" ]


Exécuter AppleScript [ AppleScript calculé : $commande ]

 

Share this post


Link to post
Share on other sites
  • 0

Bonsoir Clem,

Est-ce que cela fonctionne encore avec Mac OS Catalina ?

J'ai un message quand je lance Utilitaires AppleScript concernant les applications 32 bits. 

Share this post


Link to post
Share on other sites
  • 0

Bonjour Bertrand,

Difficile de te répondre étant encore sous OS.10.13. Mais même sous cet OS "Script Editor.app" est développé en 64bits avec une compatibilité 32bit laquelle à été abandonnée en 10.15.

dans mon terminal, la commande  file '/Applications/Utilities/Script Editor.app/Contents/MacOS/Script Editor'  retourne:

/Applications/Utilities/Script Editor.app/Contents/MacOS/Script Editor: Mach-O universal binary with 2 architectures: [x86_64:Mach-O 64-bit executable x86_64] [i386:Mach-O executable i386]
/Applications/Utilities/Script Editor.app/Contents/MacOS/Script Editor (for architecture x86_64):    Mach-O 64-bit executable x86_64
/Applications/Utilities/Script Editor.app/Contents/MacOS/Script Editor (for architecture i386):    Mach-O executable i386

le tien devrait retourner une chose ressemblant à la deuxième ligne.

Je me demande si le fait de ne pas pouvoir exécuter un AS ne proviendrait pas d'un pb  d'ajustage des autorisations dans "Préférences Système…./Sécurité et Confidentialité" => Accessibilité ou Automation (Déverrouiller cadenas, puis ajouter "Editeur de script" )

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...