Jump to content

problème de fonctionnement. sur une liste de valeur si clone


Recommended Posts

Bonjour j'ai développé une application et je rencontre un problème...curieux mais sérieux.

Si je clone  cette application sans enregistrement, je rencontre un problème de fonctionnement. (sur une liste de valeur)
Si je fais une copie à l'identique, je rencontre un problème de fonctionnement. (sur une liste de valeur)

Si je supprime les enregistrements dans toutes les fiches, autre manière de remettre à zéro,  je peux utiliser le programme sans soucis.

Ce problème se manifeste tant sur PC que sur Mac.
version FM 17

Merci pour une hypothèse de recherche.

 

Link to post
Share on other sites
il y a 24 minutes, David Julot a dit :

Bonjour,

Et quels sont les problèmes rencontrés ?

Bonjour, si je clone mon application afin quelle soit vide de tout enregistrement, une liste de valeur  ne fonctionne plus.
Mon application gère un élevage canin   et établi le pedigree, entre autre puisqu' elle gère tout un élevage,  contrats, factures, boutique, comptes, test,s expositions, carnets de santé...etc etc.
Une fois les fiches des chiens saisies, dans une rubrique père ou mère, et à partir de cette fameuse liste de valeurs  qui refuse de fonctionner, je sélectionne le père et le mère...et s'il en a été de  même dans toutes les fiches, mon pedigree est automatiquement renseigné.
J'ai cette  application avec  x chiens., contrats, facture etc etc Je suis donc obligé de supprimer toutes les fiches afin de pouvoir gérer un autre élevage.

Ce n'est pas insurmontable, loin s'en faut. Mais je ne comprends pas pourquoi le fait de faire une copie vide m'altère cette fonction.

Cordialement

Michel

 

 

Link to post
Share on other sites

Il faut voir comment est paramètrée cette liste de valeurs et sur quoi elle se base…

Si c'est une liste de valeurs statique, c'est-à-dire qu'elle contient juste une liste d'items, alors il n'y a aucun raison qu'elle ne fonctionne pas. Par contre, si elle est dynamique, c''est-à-dire qu'elle se réfère à des contenus de rubriques, alors oui une base vierge engendre une liste vierge. Et enfin si elle se réfère à des contenus de rubriques et affiche uniquement les valeurs suivant un lien relationnel, alors évidemment s'il n'y a pas d'enregistrements correspondant au lien, il y a peu de chance que cette liste de valeurs affiche des données.

Link to post
Share on other sites

Merci David, je me suis mal expliqué.
Bien évidemment, cette liste ne fonctionne plus une fois les enregistrements créés.

Au fur et à mesure que son créées mes fiches, les noms apparaissent dans cette liste. S'il n'y a pas de fiche, la liste est vide....ofcourse

Link to post
Share on other sites

D'où ma question originale ! Quand vous dites que la liste ne fonctionne pas, qu'est-ce qui ne fonctionne pas ? La liste n'apparaît pas ? Une erreur s'affiche à l'écran ?

Ce que je voudrais savoir c'est : que doit afficher la liste de valeurs, et qu'affiche-t-elle pour que vous dites qu'elle ne fonctionne pas ?

Link to post
Share on other sites

...normalement, dans la rubrique "Père",  la liste affiche la liste des chiens  et idem pour la rubrique "Mère"
Lors de la création d'un clone et avec des fiches chiens créées, cette liste reste vide.

638654306_listepre.gif.8dba5d2f96560d06a0f2d152bb333f9f.gif

Link to post
Share on other sites

Je suppose que la liste de valeurs fait référence à deux rubriques (id du chien et nom du chien). Il faut donc vérifier que les rubriques id et nom soient bien indexées et pas que de manière automatique. Quelles sont les options sélectionnées dans la définition de la liste de valeurs ?

Link to post
Share on other sites

...les rubriques sont biens indexées
et les listes de valeurs sont ainsi mâles et femelle:

570825680_listevaleurmales.gif.0c9e08b60aa3d9ed2793f42435b12592.gif

 

Link to post
Share on other sites

Si c'est une rubrique globale qui permet d'effectuer le lien vers l'occurrences Chiens et différencier les mâles des femelles, alors la raison du problème est très simple. Un clone sans enregistrement vide les rubriques de type globale alors que la suppression des enregistrements non.

Link to post
Share on other sites

YES ..super !

c'est ce que j'ai fait mais dans une autre version et dans celle ci je l'ai complètement omis.( suite à petites modifications)

Merci à toi de me l'avoir remémoré, je ne serai pas allé chercher dans ce coin là.

...Fiat lux et facta est lux

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...