Jump to content
  • 0
mediapress

FileMaker Pro advanced dans le futur ?

Question

Je viens de recevoir un email de Claris m'indiquant que dans le futur, seul les clients détenant un abonnement annuel en cours de validité ou une licence perpétuelle active avec contrat de maintenance seront pris en charge... J'ai une version Filemaker 16 Advanced, cela veut dire que quand ma version sera obsolète (en 2020), si je ne paye pas un abonnement ou un contrat de maintenance, ça sera fini pour moi ??? (en général, je mets à jour mon logiciel toutes les 2-3 versions). (Certains vont me dire que je peux garder ma version de Filemaker 16, mais il arrivera un jour ou ça ne marchera plus...)

Mode panique quand même, j'ai beaucoup investi de temps (et d'argent) dans Filemaker pour arriver à ça... 

Share this post


Link to post
Share on other sites

20 answers to this question

Recommended Posts

  • 0
Il y a 3 heures, mediapress a dit :

cela veut dire que quand ma version sera obsolète (en 2020), si je ne paye pas un abonnement ou un contrat de maintenance, ça sera fini pour moi ???

Bonsoir

Ce qui sera obsolète c'est le support (téléphonique ?) et qu'il n'y aura plus de mises à jour mineures (16.x vers 16.y).

Par contre, si votre ordi tombe en rade et que vous achetez un mac tout neuf équipé de Catalina (ou que vous passez votre mac à Catalina), alors oubliez la version 16.. Incompatibilité déjà signalé sur ce forum entre FM16 et OS 10.15.

Pour rappel, l'info support de FileMaker Claris : https://support.filemaker.com/s/article/Politique-de-support-Claris?language=fr

Tout cela nous montre que plus le temps passe et plus vite va la musique.

Share this post


Link to post
Share on other sites
  • 0

La question que je me pose, c'est est ce que je pourrai faire des mises à jour de mon logiciel sans passer par la case abonnement ou contrat de maintenance...

leur message n'est pas du tout très clair...

Share this post


Link to post
Share on other sites
  • 0

La réponse est Non. Il ne proposeront plus de mises à jours (mineures) pour la version 16.

Share this post


Link to post
Share on other sites
  • 0

non je voulais dire des mises à jour en Filemaker 19, 20, etc... sans passer par la case abonnement ou contrat de maintenance...

je ne parlai pas des upgrades mineurs...

 

Je sais que certains logiciels se vendent maintenant que par abonnement ou maintenance, j'espère que l'on aura encore le choix dans le futur... (j'ai quitté Adobe pour ça...)

Share this post


Link to post
Share on other sites
  • 0

Cela fait plusieurs années il me semble que ce n'est plus proposé. Au moins depuis que la location annuelle existe.

Share this post


Link to post
Share on other sites
  • 0

je met la réponse officielle de Claris sur ce sujet (je les ai contacté aussi), cela peut intéresser d'autres utilisateurs.

Merci de votre aide

 

 

Bonjour Monsieur Pellet,

Vous pourrez acheter une mise à niveau vers la version la plus récente tant que la version que vous possédez est toujours prise en charge par notre support. A partir du moment que la version 16 n’est plus prise en charge par notre support, le tarif de mise à jour ne sera plus disponible. 

Actuellement la fin de vie pour la version 16 est le 18 Septembre 2020, cependant cette date peut changer donc nous recommaderons de vérifier notre "roadmap" pour plus d’informations concernant la fin de vie de la version 16, et la possibilité de mise à jour vers l’éventuelle version « FileMaker 19 ».
https://community.filemaker.com/en/s/roadmap

Nous vous informons tout de même que ceci est le format de mise à jour actuelle mais nous n’avons pas la possibilité de confirmer si cette formule de mise à jour sera toujours disponible lors de la sortie de la prochaine version.

Nous restons à votre disposition pour toute information complémentaire.

Cordialement,

Share this post


Link to post
Share on other sites
  • 0

C'est la "course infernale à l'armement".

Il faut changer de logiciel parce que celui-ci ne fonctionne plus sur l'OS. Il faut changer d'ordinateur parce que le nouvel OS ne tourne plus sur les anciennes machines. Il faut tout renouveler et ça coûte des sommes folles.

Si les utilisateurs chevronnés de filemaker ont besoin des nouvelles versions — mais est-ce vrai ? —, ce n'est pas le cas de ceux qui ont des besoins plus modestes pour lesquels les dernières avancées technologiques ne sont pas utiles, voire créatrices de soucis nouveaux.

Est-il nécessaire de changer chaque année d'OS et de version du logiciel ?

Oui pour les actionnaires. Non pour les utilisateurs = payeurs.

Rien d'étonnant à ce que ceux-ci se tournent de plus en plus vers les logiciels libres.

Share this post


Link to post
Share on other sites
  • 0

Je ne vois pas trop en quoi ça change quelque chose dans ce cas.

La fin de la disponibilité de la màj FM16 interviendra avec la sortie de la 19, exactement comme d'habitude (on peut upgrader de deux versions, pas de 3).

Ensuite, les licences perpétuelles continueront d'exister (depuis quelque temps on peut même les acheter avec 5 ans de maintenance !). Je ne vois vraiment pas ce que ça change si ce n'est qu'on connaît à l'avance les dates de fin de "support".

Entre parenthèses, à quelques rares exceptions près, il n'y a jamais de màj sur les version n-1, et encore moins sur les version n-2. Donc à part la fin du support téléphonique vraiment…

Share this post


Link to post
Share on other sites
  • 0

on pourrait quand même reprocher des délais pour l'obsolescence assez court, surtout pour beaucoup d'utilisateurs qui utilisent Filemaker pour des besoins perso et dont ce n'est pas le métier... Je viens de voir que sur la version 18, le runtime avait été supprimé, cela voudra dire que je ne pourrai plus vendre de petites solutions comme j'ai pu faire auparavant... On ne peut plus non plus partager de bases de données si on n'a pas le Filemaker Serveur ou payer un abonnement pour cela... Cela évolue vers des solutions que professionnelles et délaisse le côté des petits utilisateurs...

Share this post


Link to post
Share on other sites
  • 0
Il y a 7 heures, mediapress a dit :

on pourrait quand même reprocher des délais pour l'obsolescence assez court, surtout pour beaucoup d'utilisateurs qui utilisent Filemaker pour des besoins perso et dont ce n'est pas le métier... Je viens de voir que sur la version 18, le runtime avait été supprimé, cela voudra dire que je ne pourrai plus vendre de petites solutions comme j'ai pu faire auparavant... On ne peut plus non plus partager de bases de données si on n'a pas le Filemaker Serveur ou payer un abonnement pour cela... Cela évolue vers des solutions que professionnelles et délaisse le côté des petits utilisateurs...

je vois pas ou vous avez vu que le runtime est supprimé pour la version 18 !!!!

Share this post


Link to post
Share on other sites
  • 0
il y a 3 minutes, sergebo a dit :

je vois pas ou vous avez vu que le runtime est supprimé pour la version 18 !!!!

Previously deprecated:

  • EPS image format
  • Support for 32-bit architecture
  • Support for Windows 7, 8, and 8.1
  • Support for EPS files (*.eps)
  • Container field option: “Store only a reference to the file”
  • The Get(WindowOrientation) function
  • Send DDE and spelling script steps
  • Type 1 fonts DBF import/export format
  • DDR HTML format
  • FileMaker Pro runtimes

Alors peut-être que c'est pas clair pour moi, mais comme deprecated veut dire obsolète, j'en ai fais la conclusion moi-même... Peut-être que je me trompe sur ce thème abordé, et dans ce cas là mea culpa...

Share this post


Link to post
Share on other sites
  • 0
  • 0

Bonjour,

À moi d'ajouter mon grain de sel… Le runtime est annoncé comme obsolète depuis FileMaker Pro Advanced 14, la version 18 offre encore la possibilité de générer un runtime mais avec des fonctions en moins comme annoncé. Il n'est pas dit que FileMaker Pro 18 ne peut plus générer de runtime.

Je rejoins Fabrice, vous pouvez parfaitement continuer à utiliser une version ancienne de FileMaker Pro sur un OS ancien. Surtout si vous en êtes satisfait, il n'y a pas de raison de changer. La seule chose que Claris annonce, c'est qu'elle ne continuera pas à maintenir les versions antérieures à la n-1, mais comme elle le fait depuis maintenant plusieurs années.

Maintenant on peut arguer le fait que l'éditeur devrait maintenir les anciennes versions du produit dès lors qu'un nouvel OS sort. Mais c'est ce qu'elle fait en sortant une version majeure. Si je dois prendre un exemple extrême, souhaitez-vous avoir la possibilité de maintenir la version 4.0 de FileMaker SDK (qui offrait la possibilité de générer un runtime fonctionnant en réseau) pour qu'elle fonctionne avec macOS 10.15 ? Et vous allez me dire oui !

Dans mon activité, je continue à maintenir des solutions sous FileMaker Pro 11, 12, etc. tout simplement parce que le client ne souhaite pas mettre à jour son OS et FileMaker, et il est très heureux comme ça. Maintenant, sa difficulté est d'avoir sous la main un développeur compétent qui connait ces anciennes version.

Voilà pour mon grain de sel du jour 😉

Share this post


Link to post
Share on other sites
  • 0

Merci David et bonjour de Chartres

Le problème — c'est à dire la situation où l'utilisateur est obligé de débourser beaucoup d'argent — vient justement des OS.

Dans une situation comme la nôtre, celle d'une collectivité territoriale où les budgets sont restreints, si l'on change les OS, parce qu'il est nécessaire de rajeunir le parc matériel, on va se trouver obligé de renouveler toutes les licences filemaker (environ une cinquantaine) et les passer en version 18 alors que la version 14 nous convient parfaitement.

Le problème est quasiment insoluble dans un monde où la course en avant est la seule voie proposée …

Share this post


Link to post
Share on other sites
  • 0
il y a 12 minutes, Dominique Joly a dit :

Merci David et bonjour de Chartres

Le problème — c'est à dire la situation où l'utilisateur est obligé de débourser beaucoup d'argent — vient justement des OS.

Dans une situation comme la nôtre, celle d'une collectivité territoriale où les budgets sont restreints, si l'on change les OS, parce qu'il est nécessaire de rajeunir le parc matériel, on va se trouver obligé de renouveler toutes les licences filemaker (environ une cinquantaine) et les passer en version 18 alors que la version 14 nous convient parfaitement.

Le problème est quasiment insoluble dans un monde où la course en avant est la seule voie proposée …

Bonjour Dominique,

Chartres me manque c'est un fait 😉

Pour en revenir au coût, c'est pour cette raison que Claris propose depuis quelques années l'abonnement annuel, qui permet

  • de réduire les coût : pour 5 utilisateurs 960 €/an au lieu de 2 880 € en une fois.
  • d'obtenir toutes les versions majeurs pendant la durée de l'abonnement, donc de pouvoir continuer à migrer ses OS sans surcout côté FileMaker. Et de continuer à utiliser l'ancienne version de FileMaker si l'on migre pas son OS.
  • de conserver le budget alloué d'une année sur l'autre.

Share this post


Link to post
Share on other sites
  • 0

Merci David pour ce rappel

Je transmettrai à ma DSI qui a fait un autre choix. Rester en fm 14 pour l'instant.

Share this post


Link to post
Share on other sites
  • 0
Il y a 2 heures, David Julot a dit :

Bonjour,

À moi d'ajouter mon grain de sel… Le runtime est annoncé comme obsolète depuis FileMaker Pro Advanced 14, la version 18 offre encore la possibilité de générer un runtime mais avec des fonctions en moins comme annoncé. Il n'est pas dit que FileMaker Pro 18 ne peut plus générer de runtime.

Je rejoins Fabrice, vous pouvez parfaitement continuer à utiliser une version ancienne de FileMaker Pro sur un OS ancien. Surtout si vous en êtes satisfait, il n'y a pas de raison de changer. La seule chose que Claris annonce, c'est qu'elle ne continuera pas à maintenir les versions antérieures à la n-1, mais comme elle le fait depuis maintenant plusieurs années.

Maintenant on peut arguer le fait que l'éditeur devrait maintenir les anciennes versions du produit dès lors qu'un nouvel OS sort. Mais c'est ce qu'elle fait en sortant une version majeure. Si je dois prendre un exemple extrême, souhaitez-vous avoir la possibilité de maintenir la version 4.0 de FileMaker SDK (qui offrait la possibilité de générer un runtime fonctionnant en réseau) pour qu'elle fonctionne avec macOS 10.15 ? Et vous allez me dire oui !

Dans mon activité, je continue à maintenir des solutions sous FileMaker Pro 11, 12, etc. tout simplement parce que le client ne souhaite pas mettre à jour son OS et FileMaker, et il est très heureux comme ça. Maintenant, sa difficulté est d'avoir sous la main un développeur compétent qui connait ces anciennes version.

Voilà pour mon grain de sel du jour 😉

Ok pour le runtime, merci de la précision...

Pour l'utilisation d'une ancienne version sur un OS ancien, là, je reste plus mitigé... Si Filemaker annonce un logiciel obsolète au bout de 3 ans, ils devraient faire le nécessaire pour qu'au moins pendant ces 3 ans, ils fassent des mises à jour mineures pour rendre leur logiciel compatible avec les évolutions des OS, ça me semble un peu le minimum... (Si j'achète la mise à jour FM 18 maintenant, et que en septembre prochain, Apple fasse un nouveau OS non compatible, je l'aurai dans l'os). Si Filemaker un jour passe obligatoirement par l'abonnement, je serai contraint de trouver d'autres solutions (et à regrets, parce que j'aime bien ce logiciel).

C'est là ou je rejoint Dominique sur son raisonnement, ça coute une fortune si on change à chaque OS et à chaque version de FM... Pour moi, un minimum de 3 ans de tranquillité à chaque achat serait un minimum (on ne peut pas non plus faire des mises à jour de versions trop vieille, non plus , ça je le conçois aussi). 

Share this post


Link to post
Share on other sites
  • 0
il y a 20 minutes, mediapress a dit :

C'est là ou je rejoint Dominique sur son raisonnement, ça coute une fortune si on change à chaque OS et à chaque version de FM... Pour moi, un minimum de 3 ans de tranquillité à chaque achat serait un minimum (on ne peut pas non plus faire des mises à jour de versions trop vieille, non plus , ça je le conçois aussi). 

Justement, avec l'abonnement proposé par Claris vous payez 960 € / an, toujours pour 5 utilisateurs, soit 2 880 € sur trois ans et vous avez toutes les mises à jour majeures du logiciels pendant ces trois ans. C'est donc bien une tranquillité minimum de 3 ans. Alors que si vous achetez plein pot aujourd'hui 5 utilisateurs au prix de 2 880 €, vous ne bénéficiez d'aucune mises à jour majeures du logiciel pendant les 3 ans.

Donc à prix égale, mais étalé sur trois ans, je préfère l'abonnement qui en plus me permet de recevoir les nouvelles versions, plutôt que de continuer à acheter les licences plein pot et sans recevoir les nouvelles versions.

Share this post


Link to post
Share on other sites
  • 0

Et encore, c'est encore moins cher en s'engageant sur la durée (toujours en location). 960, c'est le tarif pour 1 an, mais si on prend pour plus longtemps, il y a de belles réductions, qui viennent même d'augmenter ! (augmenter la réduction, c'est bon :) ).

C'est maintenant 15% sur la deuxième année, et 25% sur les années 3, 4, 5. Ça fait tout de même des tarifs vraiment raisonnables si on est dans une démarche long terme.

@Dominique Joly, ça fait longtemps que votre parc informatique est un problème. Je pense que comme on déduit que tout corps plongé dans l'eau n'en ressortant pas au bout d'une heure peut être considéré comme mouillé, qu'au bout d'un moment où une situation est de plus en plus problématique on peut arriver à conclusion qu'elle est mal gérée. On en a discuté plusieurs fois ici même : ça n'est pas comme ça qu'on gère un parc informatique. Vous allez dans le mur.

Share this post


Link to post
Share on other sites
  • 0

Merci Fabrice

Je suis d'accord avec ton analyse mais ce n'est pas moi qui décide et ce n'est pas faute d'avoir essayer de convaincre la hiérarchie.

Peut-être que les nouveaux arrivants dans le service DSI sauront mieux que les précédents gérer cette question.

Enfin, pour un archéologue "aller dans le mur" ce n'est pas un problème : - )

Nous les étudions de près, les murs, de toutes époques et, la plupart du temps, nous les "démontons".

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...