Jump to content
  • 0
gpto

je suis perdu.....

Question

Bonjour a tous

j'ai un problème vraiment étrange

Sur le meme modele, avec les memes données, je ne vois pas la meme chose selon le compte ou la machine....

(Je précise que pour faire cette comparaison j'ai passé le compte du client en ADMIN, comme moi, mais ca ne change rien en fait.....)

 

Je m'explique : voila ce que j'ai sur MON mac avec MON compte, tout est normal, je retrouve le 10 000 et mes totaux sont justes.....

PG-PG.png.a2e54e41b4b4634e3aa7bf43f5a7d898.png

 

Maintenant voila ce que j'ai sur MON mac avec le compte du client, les totaux sont justes MAIS le 10 000 n'apparait pas.....

LT-PG.png.f5444d55c45a6263847ce72a71cdbeff.png

 

et le top, voila ce que le client voit avec SON compte sur SON mac, toujours pas de 10 000 et les totaux sont ARRONDIS (il n'y a pas d'arrondi dans la définition de la rubrique)

LT-LT.png.3b5a6cb48c9ef19836c0dd35442610e0.png

 

ce n'est pas un problème de police, ce n'est pas un problème de droit d'accès....

De plus, ce matin le client a saisi toutes les rubriques et on ne retrouve ces données nulle part, ni lui ni moi......

Je suis largué sur ce point, je ne comprend pas pourquoi ca fait ca.....

Merci de votre aide

Patrice

 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Bonjour,

Ce n'est pas un formatage conditionnel ? Ou un Masquer object quand... ? sinon dans les privilèges du compte...

Bien cordialement,

Share this post


Link to post
Share on other sites
  • 0

pour les 10 000 je pense avoir trouvé : ces rubriques étaient en GLOBAL, prise en compte dans le calcul, pour tout le monde, mais pas affichées......

mais le client a toujours les totaux en arrondi, enfin ce ne sont même pas des arrondis (en terme de virgule je veux dire)

Share this post


Link to post
Share on other sites
  • 0

Bonjour CeydV

pour les privileges de compte non, car avec son compte sur ma machine (qu'il soit avec ses privilèges ou admin) ca ne le fait pas......

formatage conditionnel non

masquage : c'était lié a l'état GLOBAL des rubriques....

est-ce que ca pourrait être du a l'option "paramètre système" de la définition du format de nombre? Car leurs machines sont, pour la plupart, en format US-english, ils voient les montants en 300,000,000

Capture d’écran 2019-07-08 à 11.45.31.png

Share this post


Link to post
Share on other sites
  • 0

toujours le même problème, j'ai cru un moment que c'était a cause de la version de FMP (16) j'ai donc mis a jour le client en 17 et toujours pareils, des 296 550 000 transformé en 300 par exemple.....

je n'y comprend vraiment rien, surtout que de notre coté tout est OK

 

la seule différence maintenant entre leurs Mac et les nôtres, c'est la langue OS X et FMP,  ils sont tous en anglais et nous en français.....

Share this post


Link to post
Share on other sites
  • 0
il y a 37 minutes, gpto a dit :

la seule différence maintenant entre leurs Mac et les nôtres, c'est la langue OS X et FMP,  ils sont tous en anglais et nous en français.....

Oui, c'est probable qu'un calcul sur les totaux (arrondi ou autre) d'un format US puisse faire ça, si le séparateur n'est pas le même : "Point au lieu de virgule".

Avez-vous essayé sur votre machine de changer le paramètre région afin de faire un test comparatif?

Screenshot 2019-07-11 at 2.28.48 PM.png

Share this post


Link to post
Share on other sites
  • 0

Bonjour Ceyd

Effectivement cela vient de la, mais ca reste quand même très étrange, comment un chiffre saisi comme ceci 386735155 s'affiche comme ceci en formatage FR 386 735 155 et s'affiche comme ca en formatage US : 387 !!!

du coup je n'ai pas cherché plus loin, vu que le client a, certes des machines en anglais, mais préfère l'espace en séparateur de milliers, j'ai bloqué toutes mes rubriques avec séparateurs de milliers = espace et pas de "paramètres système"

reste que l'arrondi (si on peut l'appeler comme ca) de 386735155 vers 387 est un mystère, voir un bug 🙂 Je voudrais le faire express je ne saurais même pas comment faire !

Merci bonne journée

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...