Jump to content
Jérémie Gimenez

Ancien moteur d'exécution java SE

Recommended Posts

Bonjour,

FMP 18 refuse de s'ouvrir : « L'installation de l'ancien moteur d'exécution Java SE 6 est nécessaire pour ouvrir Filemaker Pro Advanced ».

Ca me le fait seulement depuis ce matin.

J'avais déjà rencontré ce souci avec FMP 17 ; j'avais supprimé l'extension Script Master, et ça s'était arrangé.

Souci : à cette heure, je n'ai aucune extension dans mon dossier FMP 18. Donc rien à supprimer…

Pourtant, c'est sûrement encore un problème de plugin : ce matin, à la première ouverture, Filemaker m'a demandé de valider l'installation de BaseElements puis de ScriptMaster (alors que le fichier en question n'utilise aucune de ces extensions, soit dit en passant)… J'ai accepté sans me méfier, et depuis j'ai ce plantage à l'ouverture !

Sauf que je ne peux virer ces extensions puisqu'elles ne sont pas apparues dans le dossier de Filemaker 18…

(Inutile de préciser que je n'ai pas une envie débordante d'aller installation des bidules Java, encore moins "anciens".)

Quelqu'un sait-il ce qu'il en est ??

Bonne journée, bonne fête !

Jérémie

Capture d’écran 2019-06-10 à 12.43.05.png

Share this post


Link to post
Share on other sites
il y a 16 minutes, Jérémie Gimenez a dit :

je n'ai aucune extension dans mon dossier FMP 18. Donc rien à supprimer…

Bonjour,

La, on parle bien du repertoire ~/Library/Application Support/FileMaker/FileMaker Pro Advanced/18/Extensions ?

Bien cordialement,

Share this post


Link to post
Share on other sites

Bonjour Cey,

Merci !

Je pensais plutôt à ~/Applications/FileMaker Pro 18 Advanced/Extensions/

Mais après vérification, dans ~/Library/Application Support/, je n'ai pas de dossier FileMaker…

Share this post


Link to post
Share on other sites

D'ac,

Et quand vous cliquez dans le Finder, et aller au dossier (MAJ+CMD+G?) avec le chemin vu plus haut, c'est pas mieux ?

Share this post


Link to post
Share on other sites

Salut

t'es sur que t'as pas un script à l'ouverture qui vérifie si tu as des extensions installées et tes les installe le cas échéant avec de vielle version qu'il a en mémoire ? 

même si tu n'utilises plus ces extensions, c'est peut-être un vieux reste du passé 

Share this post


Link to post
Share on other sites

les extensions sont maintenant dans ton dossier bibliothèque "/Users/tonusers/Library/Application Support/FileMaker/FileMaker Pro Advanced/18.0/Extensions" et plus dans le dossier application

Share this post


Link to post
Share on other sites
il y a 3 minutes, CeydV_1mt a dit :

Et quand vous cliquez dans le Finder, et aller au dossier (MAJ+CMD+G?) avec le chemin vu plus haut, c'est pas mieux ?

Bravo !

Moi, j'étais dans la Bibliothèque du HD, et non dans celle de l'utilisateur (qui était d'ailleurs cachée, jusqu'à cette heure)…

Du coup, effectivement, ça remarche après avoir supprimé ces 2 extensions !

Reste à savoir pourquoi il a tant voulu m'ajouter ces extensions ce matin.

NB : pour répondre à Esaïe, non, je n'ai pas de script contrôlant ces extensions à l'ouverture du fichier, du moins pas dans ce fichier. J'ai eu ça ailleurs, et dans des solutions sur lesquelles je développe encore en FMP16.

Un grand merci !

Jérémie

Share this post


Link to post
Share on other sites
il y a 29 minutes, Jérémie Gimenez a dit :

NB : pour répondre à Esaïe, non, je n'ai pas de script contrôlant ces extensions à l'ouverture du fichier, du moins pas dans ce fichier. J'ai eu ça ailleurs, et dans des solutions sur lesquelles je développe encore en FMP16.

Bizarre car FM crée toujours un répertoire extension vide avec les nouvelles versions, donc hormis une de tes bases qui installe des extensions, je ne vois pas comment elles auraient pu ce retrouver là.

Share this post


Link to post
Share on other sites

D'autant plus qu'il s'agit d'un fichier presque vide, créé il y a quelques jours, par le bouton "nouveau fichier vide" de la fenêtre d'ouverture.

Je n'ai encore AUCUNE fonction personnalisée dedans. A peine 3 tables sans la moindre particularité, et les rubriques de base… (Même pas des rubriques automatiques de Filemaker puisque j'ai vider le XML DefaultFields, à cause de l'absence de rubriques calculées).

Je n'ai pas importé de thème, pas copié-collé de rubriques ni script ni rien…

Pas de Source de données externes non plus…

Bref ! On saura si ça se présente un jour chez d'autres personnes !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...