Jump to content
  • 0
Noël Dubau

360Worsk Scriptmaster réticent

Question

J'ai une solution dans laquelle j'utilise de nombreuses fonctions nécessitant le plugin 360SM nombre d'entre elles issues de la compétence de l'ami Clem. Je travaille sous une machine virtuelle Windows 10 à Parallels Desktop 14. J'ai installé FileMaker Advanced 14 (et aussi 12) et la dernière version 5.1 de Scriptmaster. Le plugin est activé (Préférences / plugins)

Lorsque j'ouvre mon fichier fmp12, un message m'informant qu'il nécessite la version 4.02 de SM minimum.

J'ai bien essayé de remplacer avec l'ancienne version et là j'ai droit à une demande de version antique  java alors que la dernière est en place

Que puis-je faire? Merci et salutations !70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

Capture d’écran 2019-02-26 à 17.41.05.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

70734561_Capturedecran2019-02-27a14_26_04.png.54165b7a8be11ffd66d7ceb117587994.png

165097331_Capturedecran2019-02-26a17_41_05.png.cbf983352084c1e14764e16469d037a9.png

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Bonjour, 

Ca ne serait pas un problème de version de JAVA 32 ou 64 bits ?
Avec un FM14, 32 bits serait logique, hors W10 "appelle" certainement d'emblée une installation 64 bits sur le site d'Oracle.

Ca vaut le coup de vérifier je pense ;)

Share this post


Link to post
Share on other sites
  • 0

Bonjour

J'ai donc désinstallé la version de Java présente et téléchargé une version réputée 32bits (jre-8u201-windows-i586). 

Sous FileMaker 12 j'ai mis les fichiers d'une version 4.xx du pi et cela ne m'injurie plus... et les fonctions sont bien actives.

Sous FileMaker 14 : si je garde la version 5.1 du pi il m'est signalé que "la solution nécessite SM version 4.02 minimum ; si je mets la version 4.xx du pi j'ai le message de réclamation de version java minimale 1.5 non installée....

Cordialement

 

Share this post


Link to post
Share on other sites
  • 0

Tu n'es pas obligé de désinstaller une des deux versions de Java. Elles sont réputées savoir coexister dans un même environnement Windows.
SM 5.1 est théoriquement compatible avec FM 12 et ultérieurs.
Je réinstallerais Java en 64 (ne me demande pas pourquoi ! ) et m'acharnerais avec la version 5.1 du plug-in.
 

Share this post


Link to post
Share on other sites
  • 0

Quelles fonctions de ScriptMaster utilises-tu ? J'utilise maintenant BaseElements de Goya, plus aucun problèmes de Java. Juste le temps de s'habituer à un nouveau plug-in avec une logique différente.

Share this post


Link to post
Share on other sites
  • 0

Bonjour à tous

Je ne retrouve pas qui l'avait évoqué mais je viens de régler ce problème.

J'ai relu les scripts déclarant les fonctions ScriptMaster ! Et là bingo il y en avait un qui vérifiait la version de ScriptMaster installée ; bien que la syntaxe me parut correcte j'en ai désactivé ces lignes ; et tout fonctionne à merveille tant en 12 que 14 !

Merci de votre patience et bonne journée !

Noël

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...