Aller au contenu
  • 0
lapinzed

RESOLU Opérateurs de recherche non fonctionnels

Question

Bonjour,

Voici mon problème : Dans mes bases de données, lorsque je fais une recherche en mode recherche, en recherche rapide ou par le biais d'un script, les opérateurs ne sont pas pris en charge. Impossible de comprendre pourquoi et j'avoue que ça limite pas mal les recherches!

Par exemple, si dans un champ  il y à la donnée "NY2X34T5", je passe en mode recherche et je tape "NY*", filemaker me répondra "Aucun enregistrement ne correspond à ces critères de recherche". Tout cela sans les "" bien sur.

Pourquoi ce résultat? Comment faire pour qu'il trouve tous les enregistrement dont cette rubrique commence par "NY"?

J'ai lu la doc de FM, le post de David Julot sur fmsource, cherché partout, mais on dirait que je suis tout seul à avoir ce problème..

Pour info, j'utilise filemaker pro advanced 17 sur mac, j'ai essayé en webdirect, sur filemaker Go, mais rien n'y fait. Et la rubrique est indexée.

Merci pour votre aide! Et désolé si le sujet a déjà été traité sur le forum, mais je n'ai rien trouvé ?

Partager ce message


Lien à poster
Partager sur d’autres sites

2 réponses à cette question

Messages recommandés

  • 0

Bonjour,

Normalement, si le contenu de la rubrique est NY2X34T5, une recherche sur NY devrait donner le record. L'étoile n'est pas nécessaire, FileMaker opére la troncature à droite par défaut...donc NY correspond à dire : "donne-moi tous les enregistrements où dans cette rubrique, il y a un mot qui commence par NY."

La rubrique peut être indexée ou pas, cela n'aura d'impact que sur les performances...

par contre le type peut influencer la recherche. Est-ce bien une rurbrique de type texte ou de type calcul mais dont le résultat est de type texte ?

 

Cordialement,

Tanguy

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Merci pour ta réponse! 

Pour vérifier que le bug ne vienne pas de ma base de donnée, j'en ai créé une nouvelle avec juste un champ pour tester la recherche. Hors ça fonctionne comme tu le dis, sans mettre "*".. 

De retour sur ma base, j'ai donc été fouiller dans les options du champ : C'est bien du texte, et l'indexation était sur "toutes"

J'ai changé ce paramètre pour "minimal", et oh miracle, la recherche fonctionne!

Je pense que le problème vient du fait que j'ai réutilisé un fichier que j'ai vidé puis re-rempli avec d'autres données, ce qui a du faire buguer l'indexation. Le fait de modifier l'option a forcé FM à recréer l'index.

Bref, merci bcp, sujet résolu ? 

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à cette question…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.

Chargement

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...