Jump to content
  • 0
Pico

Gros problèmes FMP17 et Mojave

Question

Bonjour,

Rien ne va plus dans le monde Apple/FileMaker (pour moi du moins). Je travaille sur FMPA 17xxx (toutes màj faites) et pareil sous Mojave.

- J'accède à mes bases de l'extérieur (en dép^lacement) et en lolal host. Voilà que quand je suis en local host mes rubriques multimédias m'affichent un login sur mon routeur (comme si FMP accèdait à ces rubriques par l'extérieur de la société... Par contre lorsque j'ouvre ladîte rubrique avec Pdf Viewer, j'ai accès au pdf contenu. Pareil, en mode modèle, si je demande affichage des données, je "vois" le pdf dans la multimédia.

- Lorsque je cherche à ouvrir mes bases (Cde-Shift-O) afin d'afficher les bases servies en local host, aucune base ne s'affiche???

- Dans un remplace field content (Cde-=) la rubrique n'est pas toujours accessible et dans la fenêtre du calcul je ne vois pas s'afficher les rubriques des tables

- Etc… etc… ?

Je précise que toutes ces fonctionnalités fonctionnent sur les Mac non équipés de Mojave. Avez-vous ce même genre de problèmes? Avez-vous trouvé des solutions (à part investir dans un vieux Mac sans Mojave?)

Merci

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Salut Pico

Pour commencer, attention au vocabulaire que tu utilises, localhost ne veux en aucun cas dire dans le réseau local mais sur la même machine, par exemple si tu as FMP installé sur la même machine que ton FMS, ton FMP accède en localhost à ton FMS. On utilise le terme LAN quand on accède par le réseau local et WAN quand c'est pas le réseau internet. Filemaker a un système pour détecter les hôtes locaux basé sur la technologie Bonjour.

Pour en revenir à ton problème, vérifie que les ports soient bien ouvert dans le firewall, es-tu bien connecté au même réseau ? (pas sur un wifi guest par ex. ou bien même un vlan différent)

Le 04/02/2019 à 16:12, Pico a dit :

- Lorsque je cherche à ouvrir mes bases (Cde-Shift-O) afin d'afficher les bases servies en local host, aucune base ne s'affiche???

Donc tu as ajouté l'hôte via son ip ou son nom dns ?

 

Le 04/02/2019 à 16:12, Pico a dit :

Avez-vous ce même genre de problèmes? Avez-vous trouvé des solutions (à part investir dans un vieux Mac sans Mojave?)

J'ai pas encore migré et j'ai pas vu personnellement de message dans ce sens ici. si t'arrive pas à résoudre ton problème tu peux te tourner vers la virtualisation d'une ancienne version de macOS sur ta machine

Share this post


Link to post
Share on other sites
  • 0

Merci pour ton retour,

- Localhost, oui je connais les différences mais c'était du rapide et dans la terminologie utilisée par FMP en anglais. Par contre je pense que personne n'utilise un FMP sur la même machine que le FMS

- Les ports sont correctement ouverts, aucun soucis de ce côté. Mon soucis n'est pas là d'ailleurs. Le host a été ajouté pour la config interne avec son IP sur le LAN et pour la config en accès WAN avec l'IP fixe du modem. Tout fonctionne très bien de la sorte depuis plusieurs années d'ailleurs.

Pour info et afin d'en avoir le cœur net, j'ai mis la main sur un iMac late 2012 en 10.14.2 et FMPA V15 : Tout fonctionne à merveille.

Le soucis vient de FMP V17 et/ou de mon MacBook Pro sous 10.14.1. D'ailleurs il semblerait que la V17 soit largement incompatible avec Mojave suite à quelques recherches sur le net. Grrrrr!!!!!! NE MIGRE PAS!!!

 

Par contre je serais intéressé de savoir comment tu virtualise une ancienne version d'OS X ?

 

Merci

Share this post


Link to post
Share on other sites
  • 0
il y a 18 minutes, Pico a dit :

Pour info et afin d'en avoir le cœur net, j'ai mis la main sur un iMac late 2012 en 10.14.2 et FMPA V15 : Tout fonctionne à merveille.

Tu pourrais mettre la démo de la 17 sur cette iMac ? ça serai intéressant pour voir si tu rencontre le même problème

il y a 21 minutes, Pico a dit :

Par contre je serais intéressé de savoir comment tu virtualise une ancienne version d'OS X ?

Si tu as un mac qui est sur l'ancienne version, le plus facile c'est de créer la VM dessus car Fusion et je crois aussi Parallels ont une fonction d'installation à partir de la partition recovery. Sinon faut avoir un installeurs du système que tu veux, utiliser diskmakerX pour créer une clé de boot, puis dans le logiciel de virtualisation sélectionner la clé comme volume d'installation

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...