Aller au contenu

Question

Bonjour à tous,

jai essayé de jouer un peu avec cette intéressante nouvelle fonction de rubriques par défaut et j’arrive à peu près à faire ce que je veux (rubriques textes, nombres, calculées, globales, etc...) excepté une chose sur laquelle je bute: lorsque je veux inclure des rubriques statistiques, FileMaker ne crée que la première et ignore toutes les rubriques après celles-ci. Quelqu’un a-t-il rencontré ce soucis et trouve une parade?

merxi d’avance 

Gilles

DefaultFields.xml

DefaultFields.xml

DefaultFields.xml

DefaultFields.xml

Partager ce message


Lien à poster
Partager sur d’autres sites

8 réponses à cette question

Messages recommandés

  • 0

Hum, pour ma part je n'ai pas rencontré de soucis car je n'utilise pas de rubrique statistique, et le moins possible les rubriques calculs.

Ma question est quelles sont les rubriques statistiques indispensables dans toutes les tables ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

J’utilise fréquemment dans mes tables un liste dés clé primaires et le décompte de celles-ci soit pour afficher les enregistrements trouvés, soit pour aller afficher des enregistrements liés par exemple.

Et puis un peu aussi par défit peut être...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

la rubrique cible de la statistique est-elle créée avant la rubrique statistique ? (ordre dans le xml) ?

très malheureusement, FileMaker traité ce xml dans l'ordre et sans contrôle de cohérence avant, ce qui fait que si une rubrique référencée dans une autre est créée après, cela pose problème.

Ça rend selon moi cette fonction inutilisable et nous avons opté pour un fichier defaultfields vide.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour Fabrice,

Oui effectivement les rubriques sont crées selon l'ordre dans le xml, et la rubrique statistique est bien placée après la rubrique référence.

C'est juste que Filemaker semble ne plus être en mesure de créer de rubrique, quelque soit le type, après la première rubrique statistique.

Sinon, tout ce qui est avant est bien créé.

Gilles

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

hmm. étrange. certain qu'il n'y a pas une erreur de structure dans le xml ? (valise fermante manquante par exemple ?)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonsoir,

Effectivement le fichier XML n'est pas correctement formé (non valide). XML est sensible à la casse, les deux dernières balises <Field> ne sont pas fermées par </Field> mais par </field>, lignes 100 et 108.

Voici donc le fichier corrigé DefaultFields corrigé.xml

DefaultFields corrigé.xml

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour David,

Bien vu, effectivement ça fonctionne bien.

Fabrice avant donc (encore) raison.

Merci beaucoup et bone journée.

Gilles

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×