Aller au contenu
  • 0
vitseA

Paramétre Utilisateur non reconnu

Question

Bonjour à tous,

Je me permet de vous contacter afin de résoudre un petit soucis. J'ai dernierement installer filemaker Server 16. Jusqu' à là aucun soucis.

Sur le serveur nous hebergons des bases de données BackEnd. Les utilisateurs ont l'application (Clone) puis se connecter en VPN au serveur afin de charger leur données selon le parametre Utilisateur Filemaker GO.

Quand je synchronise depuis mon Ipad via Filemaker GO 15 avec l'identifiant (>parametre> utilisateur) il synchronise bien les données filtrés liées à mon paramétre utilisateur.

Par contre quand je fais la même chose avec Filemaker Go 16 il me charge l'ensemble des données sans filtrer sur mon Parametre > Utilisateur de Filemaker GO

Quand je synchronise depuis mon client lourd (Filemaker Pro advanced 16) sous windows il synchronise bien mes données filtrées selon préférence > Utilisateur

Je n'y comprends plus rien. Que se passe t-il avec Filemaker Go 16 ?

Merci d'avance

 

Partager ce message


Lien à poster
Partager sur d’autres sites

14 réponses à cette question

Messages recommandés

  • 0

Bonjour VitseA,

(Un prénom, peut-être ?)

Est-ce exactement le même clone qui est utilisé sur FM Go 15 et 16 ? A-t-il été modifié entre temps ?

Je vois une explication possible : que le clone s'ouvre de lui-même en Admin (au lieu de l'utilisateur X ou Y), et du coup, que la requête vers le fichier central ne porte pas restriction selon l'utilisateur…

Bonne journée !

Jérémie

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

J'ai utilisé le même clône pour Filemaker go 15 et 16.

J'ai l'impression que Filemaker go ne communique pas avec mon Serveur ... mais me ramene toutefois des données ( total)

Tandis que Filemaker Go 15 ouvre bien ma base backend hebergé sur le serveur et synchronise correctement

Je suis perdu :'(

Alexandre

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonsoir Alexandre,

Le choix d'une synchronisation est-il ferme ? L'option "connexion à distance" ne serait-elle pas jouable ?

Si tu envoies un clone à FM Go 16, il n'y a aucune raison qu'il affiche des enregistrements sans les avoir obtenus depuis le serveur.

Tu peux vérifier cela en créant des enregistrements de test sur le serveur, pour voir s'ils arrivent bien jusqu'aux supports mobiles.

Comment se passe la fameuse synchronisation ? Est-ce une importation d'enregistrements depuis le serveur vers la tablette ? Si oui, la sélection des enregistrements selon utilisateur se fait-elle par script ? Se fait-elle avant import ou après import ?

A suivre

Jérémie

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

Je viens de trouver une piste de réponse !

Quand je suis dans Filemaker go 16 si j'ajoute les informations de connexion dans la partie Hôte , le premier import fonctionne et vue qu'il se connecte puis se déconnecte il ne marche que pour le premier import car ("La connexion n'est pas cryptée")

Je précise que sous Filemaker Go 15 je n'ai jamais eut besoin de mettre mon serveur dans la partie Hote de filmeaker GO est il synchroniser parfaitement !

Cordialement

Alexandre

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Dans Filemaker Go 16 il synchronise correctement à partir du moment ou je renseigne Hôte avec mon serveur ( IP ET Nom du serveur).

Dès lors la synchronisation se passe bien.

Si j'utilise Filemaker Go 15 je clique juste sur synchroniser avec aucun hôte défini et ça fonctionne parfaitement.

Je ne souhaite pas devoir faire entrer un nom d'hôte à mes utilisateurs !

C'est quoi le soucis ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Peux-tu envoyer une capture de ton script "Synchroniser", stp ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Le soucis ne vient pas du script étant données que quand je met dans la partie Hôte de filemaker Go 16 mon Ip serveur et le nom il trouve bien le serveur et quand je synchronise il filtre bien les données depuis le serveur.

Le soucis vient de la connexion avec le serveur sous filemaker Go 16

Là ou sur filemaker go 15 on voit bien la base BackEnd s'ouvrir lors de la synchronisation

Sur filemaker Go 16 il y a juste un chargement mais le serveur ne s'ouvre pas à distante mais il me ramene quand meme des données ( correspondant à toutes les données du serveur)

Vraiment étrange

Cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je voulais voir le script pour, peut-être, comprendre ce que fait cette synchronisation…

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Jeremie,

Voici le script de l'application (Clône)

C'est un des Sous script qui fait partie du processus de synchronisation

1345663946_Sanstitre2.jpg.f5a785c56aed92a31fd841ed2a616695.jpg

Et le script qui s'execute coté serveur

1613741512_Sanstitre1.jpg.844988f58fb818d210ad987da8584e41.jpg

Et ça marche parfaitement dans 3 situations  :

Filemaker Go < version 16 et 17

Filemaker Pro advanced

Filemaker Go 16 et 17 si je renseignes dans la partie Hôte le nom du serveur

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Le souci ne me saute pas au yeux tout de suite…

- Peut-on voir la source de données externes "Tableau de Bord Backend" dans le fichier clone ?

- Après le pas de script 5 Exécuter Script Filtre PeopleS_FM, une détection d'erreur serait intéressante : Si Erreur, Boîte de dialogue avec le code d'erreur, Fin de script ; le support mobile retournerait sûrement une info intéressante.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Comme je te disais il ne s'agit pas d'une erreur de script. J'en suis sûre à 100%.

Dans Filemaker go 16 sur IPAD quand je synchronise comme ça le clône, j'ai l'impression qu'il ne se connecte pas au serveur.

Sur le serveur je met un ouvrir boite de dialogue avec $$IDPEOPLES au script Filter_PeopleSFM

Quand je lance depuis Filemaker Go 16 il ne me renvoi rien.

Neamoins quand je vais dans la partie Hôte de Filemaker GO et que je paramètre mon serveur (IP et Nom)

Je retente de synchroniser et là ça marche.

Or je ne veux pas que chaque utilisateur ait un accès au serveur.

Dans Filemaker Go 15 je synchronise et automatiquement il se connecte au serveur sans soucis.

Je précise que j'ai récemment installer Filemaker Serveur 16

Est-ce que c'est liée au Certificat SSL ? Mais alors pourquoi j'ai aucun soucis avec Filemaker Go 15 niveau communication avec le serveur Filemaker Server 16 ??

Le soucis vient clairement de la communication entre Filemaker Go 16 et 17 et Filemaker Server 16 ! Ils ont changés un truc !!!

Cordialement

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 4 heures, vitseA a dit :

Neamoins quand je vais dans la partie Hôte de Filemaker GO et que je paramètre mon serveur (IP et Nom)

Je retente de synchroniser et là ça marche.

C'est ça qui me fait m'interroger sur la source de données externes, comme si FM Go attendait que l'hôte soit défini au niveau de l'app pour le rendre accessible en tant que source de données.

Cependant, je n'en sais pas plus sur des différences entre les versions de FM Go à ce niveau.

Bon courage !

Jérémie

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

peut-on avoir le détail du pas de script 12 de Filtre_people (Restreindre) ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Salut,

J'ai donc localisé le soucis après deja un long moment de galere !

j'ai créer une petite base (Essaie) que j'ai hebergé sur mon serveur

Lorsque j'ai migré mon fichier j'ai activé les options suivantes :

Fichier / Partage / Partager avec client Filemaker /

Activé / Tout utilisateur

et Fichier / Partage / Activer ODBC/ JDBC/

Activé / Tout utilisateur

Dans cette base il y a que :

1 modèle (avec des données)

1 script qui se nomme (Filtre)

Le script et le suivant :

Gestion des erreurs [Oui]

Auto.Annulation Utilisateur [Non]

Définir variable $$Utilisateur ; Valeur : Obtenir (NomUtilisateur)

Activer le modele MonModele

Restreindre ensemble trouvé [Rétablir] ou ma colonne == $$Utilisateur

Une fois que j'ai fais ça passons à la version Clône

Dans cette version (Essaie1) il y a un script importation

Gestion des erreurs [Oui]

Auto.Annulation Utilisateur [Non]

Executer script (Gérer source de données externes ou j'ai défini mon serveur fmnet:/monIpServer/essaie (Je séléctionne le script du serveur à executer par la commande Executer Script)

Importer enregistrements ( de ma table serveur vers ma table clone)

Quand j'exécute ça depuis Pro advanced ça marche parfaitement : il lance le script du serveur et m'importe bien les enregistrements restreinds

Je passe sur filemaker GO 16 il me renvoi tout les enregistrements ? Pourquoi ?

Il n'execute tout simplement pas la ligne de code executer script ( de ma source de données)

Alors j'ai rajouté une ligne avant executer Script qui est :

Ouvrir fichier [ouvrir (masqué): Oui; Mabase)

et voila donc le message de mon IPAD  :

352537411_Sanstitre3.thumb.jpg.1840f9f92d3945b12add5649d9e785ef.jpg

Si je clique sur Se connecte ça marche script par script

Si je fais toujours autoriser la connexion et que j'ai plusieurs import tout ira bien

Neamoins dans la partie Hôte de Filemaker Go les utilisateurs ont accès au serveur et à se qui est hébergé et les utilisateurs auront ce nouveau pop-up supplémentaire qui n'etait pas là sous filemaker go 15.

Nous ne souhaitons pas avoir ce type de pop-up dans l'idéal.

Sur filemaker GO 15 il n'y avait pas ce soucis, il se connecté automatiquement à ma source sans sécurité

Est-ce que j'ai oublié d'activé un truc sur le serveur ou autre

Si vous avez une idée qui me débloque cette situation je vous serais reconnaissant

Merci d'avance

Alexandre

 

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • En ligne récemment   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×