Jump to content
murielvdb

Exportation De 29300 Enregistrements Et Résultat Processus "bizarre"

Recommended Posts

Bonsoir,

Je suis en train de transférer un panier de 29300 enregistrements dans une table.

Mon script transfère les enregistrements dans une table sélection et supprime ces enregistrements sur la table Panier et sur une table Personnes.

Le script marche très bien sur une sélection de 300 enregistrements, j'ai fait pas mal d'essais.

Là je suis en train donc de transférer 29300 enregistrements et j'ai un comportement bizarre de la fenêtre.

Jee suis sur la table Panier et la barre de défilement de progression sur la droite n'avance pas. pire : les point bleu de progression disparait t réapparait et ça me fait ça tout le temps pendant que mon script travaille.

Pareille pour la barre de défilement horizontale en bas

Qu'est-ce qu'il se passe ?

Share this post


Link to post
Share on other sites

Comment fonctionne ton script ? Quelles sont ses étapes ?

Share this post


Link to post
Share on other sites

Tu changes de modèle dans ton script ? Si c'est le cas, ne cherches pas plus loin… et a priori, pas de souci (tiens encore une plante).

Share this post


Link to post
Share on other sites

Je te le mets ci-dessous

Là l'export c'est fait

J'ai bien mes 29300 dans ma table sélection.

script en pièce jointe en 2 parties.

La galère c'est que maintenant j'ai des points d'interrogation partout où les enregistrements ont été transféré. le script est supposé les supprimer.

Je te mets aussi la capture écran du pataques dans un autre message, là c'est trop lourd

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

script1.tiff

script2.tiff

Share this post


Link to post
Share on other sites

Elle est pas claire ma phrase :

J'ai des points d'interrogation sur le modèle d la table Fichier "Liste" d'où les enregistrements étaient transférés.

Normalement, le script doit me supprimer les enregistrements transférés

Je te mets mon graphe aussi si ça peut aider

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Graphe.tiff

Share this post


Link to post
Share on other sites

Je viens de refaire toute l'exportation de mes 29300

J'ai toujours mes barres de défilement qui disparaissent et réapparaissent tout le temps du processus mais, par contre, cette fois-ci, je n'ai plus les points d'interrogation sont le modèle où les fiches sont supprimées. Elles sont bien supprimées cette fois-ci.

Mais, quand même, ça me paraît pas bien stable tout ça ! :crying:

Il faut peut-être que je fasse mon script différemment ? Non ?

j'ai peut-être trop de variables et définitions de rubriques.

C'est bien simple, je ne respire plus pendant l'exportation !!! :lol::lol:

Share this post


Link to post
Share on other sites

Pas bon ça tes points d'interrogations. Il y a de la corruption de fichiers dans l'air. :ninja: C'est dû plus à de nombreuses manipulations et recopiages de données qu'aux scripts.

Exporte les données de tes tables dans des fichiers Mailing ou Excel

Fais un clone de ta base et réimporte tous tes fichiers

Share this post


Link to post
Share on other sites

Je persiste, et comme Philippe, je pense que ton clignotement des barres et tes problèmes de ? sont deux choses différentes. Quand dans une boucle tu passes rapidement d'un modèle à un autre cela ne se manifeste à l'écran que par un clignotement comme si FMP n'avait pas le temps d'afficher alternativement tes modèles, mais que ça le chatouille ce qui se manifeste par le clignotement des barres.

Parallèlement, ton fichier est vérolé, mais ce n'est pas forcément lié.

Share this post


Link to post
Share on other sites

VÉROLÉ !!!!!! :ninja::ninja::ninja:

OK je vais faire dÉjà comme dit Philippe.

Et donc Christophe, il faudrait que ça ne change pas de modèle mon script ?

Mais il va chercher les donnÉes dans d'autres tables ? Comment je peux faire alors ????

Bonne nuit, j'abandonne pour ce soir, j'y verrais plus clair demain.

Merci à tous les 2.... Que ferais-je sans vous ! :hello:

Share this post


Link to post
Share on other sites

Tu as raison Christophe,

C'est vérolé, je ne peux même pas exporter l'intégralité en Excel, Le Excel plante. ) à 10388 sur 35000 enregistrements.

Arggghhhh !

Là j'abandonne vraiment pour ce soir. A+

Share this post


Link to post
Share on other sites

Et donc Christophe, il faudrait que ça ne change pas de modèle mon script ?

Non, pas de problème à sauter d'un modèle à un autre dans la boucle. C'est juste l'affichage qui est bizarre pendant que le script s'exécute. Mais si tu fermes les yeux, tu ne t'en rends pas compte !

Share this post


Link to post
Share on other sites

Bonsoir,

Bon j'ai tout refait mes docs d'import :drop::drop:

Tout est bon maintenant mais il y a un truc que je ne comprends pas.

Quand ma sélection est dans mon panier, j'ai créé dans le panier une rubrique "Adresse Pers ou autre" qui est une case à cocher.

Cette rubrique cochée me servira ensuite à affecter les enregistrements correspondants qui seront dans la sélection définitive dans les champs d'adresse perso ou autre de la personne. Donc, comme ce fichier me sert juste à faire un travail de sélection d'adresse, j'importerai les enregistrements cochés dans les champs correspondants de mon fichier qui importera.

Bref, j'ai créé cette rubrique dans le panier mais les données ne veulent pas se mettre dans la sélection lors de la Validation du panier et je ne comprends pas pourquoi.

J'ai essayé

Définir variable ($adresse : sel_PAN::Adresse Perso ou Autre)

Puis

Définir rubrique (Selection::Adresse perso ou Autre ; $adresse)

J'ai aussi essayé

Définir variable ($adresse : Panier::Adresse Perso ou Autre)

Puis

Définir rubrique (Selection::Adresse perso ou Autre ; $adresse)

Ni l'un ni l'autre ne marche et je ne comprends pas

Je remets mon script (en 3 parties ) et il y a mon graphe plus haut

Merci pour une petit aide ! o:)

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

script1.tiff

script2.tiff

script3.tiff

Share this post


Link to post
Share on other sites

Me revoilou.....

J'ai un problème (je crois !) avec mon script mis en 3 pièces jointes, en avant dernier message de ce post.

Ca fait 1heure que j'attends que mon panier transfère dans le modèle Sélection, et ça tourne toujours pour transférer 35463 enregistrements !!!! :ninja::ninja::ninja:

Ca me parait bien long !!!!

Vous en pensez quoi ?

Share this post


Link to post
Share on other sites

Salut Christophe,

Ben je crois que c'est ce que je fais non ? Ca copier le panier dans Sélection, puis ça supprimer dans le panier et dans Liste.

J'ai laissé tourner et ça m'a fait le transfert au bout de plus de 2 heures !!!!

Ca me parait bizarre quand même !

Share this post


Link to post
Share on other sites

Moi je pensais à l'action de script "Importer". Dans Panier, tu sélectionnes les enregistrements à exporter, tu ouvres une fenêtre en affichant la table sélection et dans celle-ci tu importes toutes les données sélectionnées dans le Panier via Importer (en précisant la correspondance des rubriques). C'est plus rapide tant à écrire qu'à s'effectuer.

Notes que le nec plus ultra est une transaction comme l'explique Fabrice dans un des derniers 1 More Tube… Mais je n'ai pas encore tout assimilé.

Share this post


Link to post
Share on other sites

En fait j'ai un premier script qui importe dans le Panier. Ca , ça va.

Et j'ai un second script (celui que j'ai mis en pièces jointes) qui se fait à partir du Panier et qui exporte dans Sélection. C'est celui-là qui prend 2heures.

Je vais regarder ce que tu me dis et chez Fabrice.

Mes canalisations eau chaude ont gelé !!!!! :ninja::ninja:

Un bon truc, le sèche-cheveux sur la canalisation au départ du ballon d'eau chaude. Comme c'est conducteur..... Ca marche !!!!!

Share this post


Link to post
Share on other sites

Bonsoir Muriel,

Tu as beau avoir de la patience, une à deux heures pour une importation ça n'a pas de sens ! Pour 40 000 fiches, cinq grandes minutes devraient suffire.

Les causes de ralentissement peuvent être des calculs qui font appels à des valeurs stockées dans d'autre tables.

Pour identifier la ou les causes, effectue des imports sur des quantités de fiches plus faible 1000 maxi dans une copie de ton fichier. Dans un premier temps décoche la case "Entrer automatiquement les val. prévues pdt import". Puis tu réimportes en décochant toutes les entrées automatiques de rubriques et tu réimportes en plusieurs fois de suite en les réactivant une à une jusqu'à tomber sur celle qui te plombe.

A nouveau bon courage

Share this post


Link to post
Share on other sites

Bonsoir Philippe;

Si tu as regardé mon script, ça va chercher les valeur 2 tables plus loin "pan_FIC", donc ça passe par le panier pour aller chercher dans la table Fichier

Tu crois que c'est ça qui ralenti ?

Il faut que les rubriques soient créées dans le panier au moment de l'importation du Fichier au Panier ?

Tu me donnes ton avis ?

Share this post


Link to post
Share on other sites

Oui mais mon script importe du fichier par le panier puis va supprimer dans le panier et dans le fichier.

Ca me parait bien ça

Je vais pas faire 50 000 scripts ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...