Jump to content

Alsete

Membres
  • Content Count

    19
  • Joined

  • Last visited

About Alsete

  • Rank

Profile Information

  • Gender
    Homme
  • Location
    SETE
  • Interests
    FMP 16 en usage privé.
    Création des BDD simples pour gérer du contenu (vidéos, musique, fichiers divers).
    Mettre en place un outil personnalisé de gestion d'association.

FileMaker Profile

  • FM
    16
  • OS
    MacOS 10.13 & 10.14
  • Certification
    --Non certifié--
  • Claris Partner
    --Non membre--

Recent Profile Visitors

406 profile views
  1. Bonjour à tous, Soient deux rubriques : Date et Valeur numérique J'aimerais faire apparaitre sur l'enregistrement du jour J la progression en % de la valeur numérique par rapport à une date antérieure. Ex : pour la date J, valeur numérique = "10" A la date J+x, valeur numérique = "12" Rubrique que je cherche à créer sur l'enregistrement du jour J : affiche "20 %" Après des recherches, je n'ai rien trouvé concernant ce type de calcul qui me semble être d'utilisation courante. Mon intuition : créer une rubrique intermédiaire avec un calcul donnant le résultat d'un autre enregistrement. Ensuite créer une rubrique avec calcul de division (ex : 12/10) en mode d'affichage pourcentage. Quelqu'un pourrait-il me donner une piste ou une solution ? Merci d'avance
  2. Merci Jean-Louis pour ta réponse rapide et efficace ! Dans la configuration du graphique, j'ai saisi la série des X - en suivant tes bons conseils - non pas en données d'une rubrique, mais en mode calcul : Cas ( JourSemaine (Table::Date)=5 ; Table::Date ; "") ...et ça fonctionne parfaitement ! Quant à l'inclinaison de la date, j'avais oublié d'utiliser cette fonctionnalité. Ça me sera bien utile quand les semaines se seront accumulées sur mon graphique. Merci beaucoup pour ton aide Alain
  3. Bonjour, Dans un modèle, j'ai des rubriques de valeurs numériques que je visualise dans plusieurs graphiques avec navigation par un panneau à onglets. Ces graphiques ont tous une même rubrique "date" en abscisse. Pour un de ces graphiques, je voudrais faire figurer en abscisse que les jeudis, les autres jours correspondant à une valeur nulle en abscisse. Sinon, pour une longue période, mes dates seraient illisibles, car enchevêtrées. Pour ce faire, je n'ai rien trouvé dans la configuration du graphique. Comment procéder pour contraindre le graphique à ne porter en abscisse que les jeudis ? - à partir du fait que seul les jeudis correspondent a une valeur non nulle pour la rubrique en ordonnée ? - en créant, juste pour ce graphique, une rubrique "date2" liée à la rubrique "date", en y adjoignant un calcul sur les dates ? Pour aucune de ces pistes, je ne trouve de solution pratique alors que je présume que c'est possible de faire cela. Merci pour votre aide et vos suggestions. Alain
  4. Bonjour et merci Magalie pour cette piste de recherche. J'ai commencé à developper ma base sous FMP 16 et j'ai téléchargé FMP 18 Advanced justement pour tester le fonctionnalités avancées. Je les ai explorées, mais pas lors de la session incriminée. J'étais en train de faire des copiés-collés de modèles et auparavant j'avais travaillé sur des scripts et fonctions et menus personnalisés. En clair j'ai fait beaucoup d'actions différentes lors de cette session et je serais bien en pense de dire laquelle a bien pu modifier mon statut d'utilisateur. Je rédigeais ou adaptais des scripts pour mes modèles et rien qui laisse penser qu'ils puissent avoir une conséquence sur la le fonctionnement de FMP. Il y a eu certainement une fausse manipulation, mais elle ne concernait pas le menu Fichier > Gérer > Sécurité où je ne suis certain de pas être allé (j'étais à autre chose que de configurer FMP) et je n'ai aucun moyen de vérifier quels sont les paramètres, n'ayant plus accès à ces menus en tant qu'utilisateur lambda que je suis devenu. Maintenant je travaille sur des copies et j'ai mis deux administrateurs, Admin et mon prénom.
  5. Un script délétère, c'est possible car je venais d'adapter des scripts à partir d'une autre base au lieu de les réécrire entièrement, et je n'ai pas du m'apercevoir qu'une fonction pointait vers un élément manquant ou défaillant... Désormais j'éviterai les copier-coller pour les scripts, ça m'aura servi de leçon. Bien que n'ayant pas les droits d'admin, j'avais quand même accès à la table des scripts et j'avais effacé tous les ajouts, en vain. Sans doute que le mal était fait. En fait j'avais commencé une base de données mal construite et je cherchais à intégrer les modèles à une base de gestion de données que j'avais trouvée. Les noms de rubrique ne correspondant pas, j'étais en train de les modifier sur mes tables et mes modèles et adapter les scripts que j'avais copié-collé. J'avoue que c'était un peu hasardeux. En fait j'aurais du réécrire toute ma base et les scripts avec mes noms de rubriques. Encore merci de m'avoir fait comprendre une erreur de stratégie.
  6. Bonsoir Puimoisson04 et merci. Bien longtemps avant le krach, j'avais exploré FMP 18 et il se trouve que j'avais mis mon nez dans la sécurité en renommant les identifiants d'ouverture. J'avais donc mon prénom en ID et un mot de passe facile. L'ouverture se faisait normalement avec ces identifiants. Le double-clic ouvre la fenêtre de connexion, même sans les raccourcis clavier. J'ai bien accès à ma base de données, en mode utilisation mais plus accès aux menus réservés à l'administrateur. Je ne peux donc plus poursuivre sa construction. D'un point de vue pratique, j'ai lancé l'enregistrement de la base que j'avais fait il y a quelques jours et je travaille maintenant sur une copie de cette copie. J'ai refait les mêmes gestes que ceux au cours desquels j'ai perdu les droits admin et rien ne s'est passé cette fois-ci. Donc a priori je n'avais pas fait de fausse manœuvre et je ne suis pas allé dans la Fichier > Gérer > Sécurité au cours de cette session maléfique. J'aurais aimé comprendre pourquoi ça s'est produit, pour éviter une séquence successible de m'ôter les droits admin, mais je ne vois pas, je n'ai rien fait de très extraordinaire, travaillant sur des modèles et scripts que je copiais depuis une base d'exemple, ceci après avoir créé une table dédiée dans ma base, même pas liée pour l'instant à mes autres tables. Sur les captures d'écran que j'ai jointes précédemment, j'ai les droits admin (dans les préfs) mais ce n'est pas le cas dans réalité. Selon moi il s'agit d'un bug.
  7. Bonjour, Je suis en train de créer une base de gestion de contenu avec FMP 16. En testant la version d'essai de FMP 18 Advanced, tout allait très bien jusqu'à aujourd'hui. Alors que j'étais en train de copier un modèle par copié-collé depuis une autre base, je suis passé en mode utilisateur et je me suis aperçu que je ne pouvais plus revenir en mode modèle, qui était devenu grisé. La plupart des menus de FMP sont inaccessibles, dont le menu "Fichier", ce qui ne me permet pas de regarder du côté des jeu de privilèges. J'ai tenté de relancer la base de données sous FMP 16 : pas de changement. Je crains fort qu'il y a un problème avec les jeux de privilèges. Dans ce cas j'imagine qu'il y a de fortes chances que FMP me voie désormais comme un simple utilisateur sans privilèges et qu'il y n'y ait guère de chances que je reprennes la main. Si c'est bien cela, ça ne semble par déranger FMP qu'il n'y ait plus d'administrateur de la base de données. C'est parce que je crois qu'il est impossible que FMP accepte l'absence d'admin que je garde espoir que le problème vient d'autre chose, que je pourrais corriger. Je précise que je n'ai pas créé d'autre compte que le compte administrateur, que je me connecte sans problème à la base avec mon identifiant et mdp. A moins que quelqu'un ait un début de solution à me proposer ? J'avais fait une sauvegarde mais depuis j'ai saisi beaucoup de choses, tables, modèles, scripts hier... et ça m'ennuierait de devoir passer des heures à tout refaire, à retrouver les sources qui m'ont aidées pour les scripts, notamment. Merci pour votre aide. EDIT : copies d'écran des privilèges (dans les préfs)
  8. Bonjour, @Philippe ROTTIER : effectivement il n'y aura plus de liens hypertextes, sinon on aurait choisi Hypercard comme nouveau nom ! 🤪 --- Du coup, est-ce que le forum FMSource changera de nom ? Je n'ose pas imaginer le travail que ça supposerait, référencement, etc.
  9. Bonsoir, Auto-réponse : j'ai trouvé comment faire en adaptant un script donné par Christophe (Puimoisson04) en 2015 et que j'ai pu lier à un bouton. Au préalable j'avais créé deux rubriques globales date_debut et date_fin avec chacune un calendrier déroulant et j'obtiens finalement une visualisation de mon graphique pour une période donnée : Alain
  10. Bonjour, J'ai créé un graphique avec la date en abscisses et 3 rubriques numériques en ordonnées. Au fil des jours le graphique se tasse et devient illisible par excès de dates en abscisses. Je ne parviens pas à trouver comment procéder pour placer des bornes sur mon graphique. Je réfléchis à une solution consistant à créer deux rubriques "date_debut" et "date_fin" dans le modèle générant le graphique de sorte que ça ne présente que cet intervalle de dates en mode graphique. Je suppose que je dois créer une rubrique globale pour la recherche dans cet intervalle de date ainsi que des scripts, mais je n'ai rien trouvé pouvant m'indiquer la marche à suivre ou tout au moins dans quelle direction m'orienter. L'aide de FMP propose uniquement le mode recherche (que je ne maîtrise pas du tout) mais pas de solution en mode utilisation. Pour autant, est-ce possible de sélectionner un intervalle de données par des scripts en mode utilisation ? Merci pour votre aide
  11. Bonjour, Merci Philippe Bien sûr, ça fonctionne maintenant ! C'est bien ce que je supposais intuitivement : j'avais bien recopié rubriques, listes de valeurs et scripts mais il fallait lier les scripts quelque part dans l'interface. La seule chose que j'avais trouvée, c'est que je pouvais exécuter (et non déclencher) le script en le sélectionnant dans la fenêtre de rédaction des scripts, puis ⌘_R. Ton aide a considérablement amélioré l'ergonomie de ma base de données. D'ailleurs ça avance bien, boutons de navigation, corbeille du conteneur, remplissage automatique de la rubrique "Titre" lors du dépôt du document dans le conteneur, affichage de sa taille, envoi par courriel. Ça devrait suffire pour l'instant... pour ce projet là. Encore merci, Alain
  12. Bonjour, Je ne parviens toujours pas à implémenter la recherche dans ma base. J'ai refait scrupuleusement à l'identique le modèle proposé par Philippe, er là je me suis aperçu qu'il y avait une différence à l'arrivée : en mode modèle, mes deux rubriques globales ont un aspect différent. Celles de Philippe contiennent le logo "script" et pas les miennes. J'en ai déduit que ces deux rubriques ne sont pas liées à leur script respectif : Philippe Moi Le résultat en est que le menu déroulant de la recherche affiche un point d'interrogation et que la saisie dans la recherche rapide est inopérante. J'ai cherché en vain dans la configuration des rubriques quelles différences j'aurais pu introduire et je n'en ai trouvé aucune. Je n'ai rien trouvé sur Internet à ce sujet, comme si la solution était évidente. Où alors faut-il passer ailleurs que par la configuration des rubriques et des scripts pour les lier ? J'ai cherché partout, dans tout ce qui accessible : les rubriques, les scripts, la lise de valeur, l'inspecteur, un éventuel bouton caché derrière les rubriques, pas de différence visible entre les deux solutions. Je précise que toutes ces rubriques sont dans une seule table. Si quelqu'un pouvait me suggérer qu'elle pourrait être la raison de l'absence de lien alors que les deux rubriques globales sont bien pointées dans leur script respectif ? Bon weekend, Alain
  13. Bonsoir, J'ai refait ma base entièrement : le tri en mode liste se fait bien dans les deux récapitulatifs en suivant les conseils avisés de Philippe. Cependant les fenêtres de recherche en en-tête dans le modèle de tri sont inopérantes, que ce soit les rubriques "recherche" ou "recherche rapide" que le bouton pour tout ré-afficher. J'ai vérifié les scripts, les rubriques et la liste de valeur. Comme les trois modules ne fonctionnent pas, je pense que j'ai mal configuré une rubrique en amont, en l'occurrence la rubrique statistique nommée "decompte". Bien sûr dans l'exemple de Philippe, il n'y a qu'une rubrique pour l'exemple, nommée "Enregistrement", alors que ma base comporte maintenant de nombreuses rubriques de saisie d'informations : titre, auteur, format des fichiers (PDF, audio, etc), descriptif, date de modification, conteneur pour le document et bien sûr les deux rubriques concernées par le tri dans les récapitulatifs, renommées "Domaine" et "Catégorie" . Quelle devrait être la configuration de cette rubrique-statistique, si toutefois le problème vient bien de là ? Ou alors faut-il conserver la rubrique "Enregistrement" en lui attribuant un calcul par exemple ? Ou introduire un script ? Merci d'avance pour votre aide. Alain
  14. Bonjour, Merci beaucoup Philippe pour ta réponse et pour avoir pris le temps de créer un exemple J'ai greffé ta solution à ma base, ça n'a pas fonctionné et j'ai des messages d'erreurs dues à des rubriques et des scripts. La cause évidente du problème : je suis parti de la solution de gestion de contenu proposée par FMP, elle intègre des fonctionnalités assez poussées, comme le choix de pochette ou autres dès qu'on place un fichier audio, un vrai iTunes dans la base ! Surtout il y a déjà en place des outils de tri, je les ai retirés en pensant régler le problème, mais en vain. Plutôt que de perdre du temps à trouver ce qui interfère avec l'outil de tri que tu m'as indiqué, je vais refaire ma BDD ex nihilo : clé, horodatages, rubriques pour la saisie et le tri. Une solution simple sans gadgets me satisfera dans un premier temps, je verrai ensuite si je peux y greffer d'autres fonctionnalités. Je vous tiendrai informés de la suite. Encore merci pour ton aide. Alain
  15. Bonjour, Je suis en train de créer un gestionnaire de contenu pour faire un peu de rangement dans mon disque dur (PDF, audio, etc.). En fait je suis parti d'un modèle fourni par FMP : "Gestionnaire de contenu" que je modifie pour l'adapter à mes besoins. Je dispose d’un modèle de saisie des données « Détail du contenu » et un modèle « Contenu » de présentation des enregistrements sous forme de liste. J’obtiens bien ma liste d’enregistrements triés par catégorie grâce à une clé de tri nommée <<CATÉGORIE>> dans un en-tête sous récapitulatif : tous les enregistrements sont bien présents dans la liste et bien regroupés par catégorie, de cette façon : LITTERATURE enregistrement A enregistrement B etc. SCIENCES enregistrement C enregistrement D enregistrement E etc. J'aimerais maintenant créer des sous-catégories afin d'obtenir ce qui suit dans ma liste récapitulative des enregistrements. Après recherche sur Internet je n'ai pas trouvé de descriptif pour hiérarchiser une liste de contenu sur plus d'un niveau mais je ne désespère pas que ce soit possible : Lorsqu'il y aura des centaines d'enregistrements avec des dizaines par catégorie, la navigation dans la liste serait moins fastidieuse. Ce serait immédiatement visualisable et éviterait de passer constamment par le mode recherche pour taper l'intitulé d'une sous-catégorie. SCIENCES BIOLOGIE enregistrement 1 enregistrement 2 etc. CHIMIE enregistrement A enregistrement B etc. PHYSIQUE enregistrement X enregistrement Y etc. Dans ma table j'ai deux rubriques pour le tri : Clé de tri pour la liste avec comme formule de calcul : ResultatRubrique ( Trier la sélection ) Sélection de tri avec comme formule de calcul : Si ( EstVide ( Contenu ) ; "CATÉGORIE" ; Contenu ) Voici comment se présente le modèle en question : Pour l'en-tête de <<CATÉGORIE>> le survol de la marge donne : Sous-récapitulatif par Clé de tri de liste (en-tête) Pour l'en-tête de <<Sous_catégorie>> ça donne : Sous-récapitulatif par SOUS_CATÉGORIE (en-tête). Il n'est plus question de clé de tri et je ne serais pas surpris que ce soit anormal. Ceci après avoir créé dans ma table une rubrique SOUS_CATÉGORIE et une rubrique Sélection de tri SOUS_CATÉGORIE avec comme formule de calcul : Si ( EstVide ( Contenu ) ; "SOUS_CATÉGORIE" ; Contenu ). J'ai créé et configuré de la sorte cette rubrique de sélection de tri par pur instinct mais ça ne semble pas être la bonne voie Est-ce faisable et comment procéder ? Merci pour vos réponses Alain
×
×
  • Create New...