Jump to content

NoémiV

Membres
  • Content Count

    23
  • Joined

  • Last visited

About NoémiV

  • Rank

  • Birthday 09/20/1981

Profile Information

  • Gender
    Femme
  • Location
    Basel, Suisse
  • Interests
    Egyptology, Archaeology

FileMaker Profile

  • FM
    FMP18A
  • OS
    OSX10.14
  • Certification
    --Non certifié--
  • FBA
    --Non membre--

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. C'est génial, exactement ce dont j'avais besoin, et en plus j'ai appris quelque chose de nouveau merci beaucoup !!!!
  2. Merci pour ces informations ! Alors j'ai pour le moment vraiment des rubriques statistiques, mais je vois que ce n'est pas la bonne solution. Le problème, c'est que je ne comprends pas quel calcul je devrais faire pour récupérer les données de mes rubriques de subsites ... (me sens bien nulle pour le coup) Je mets en lien la base, comme ca tu pourras voir par toi-même ce que j'ai fait. tu tombes au départ sur un menu, et il faut aller dans Sites et Subsites. les rubriques statistiques se trouvent dans les onglets "Remains" par exemple, mais aussi Written material, etc. grosfi.ch/W4YC6NrYhWL
  3. Bonjour ! Question à laquelle je ne trouve pas de réponse sur le forum : Est-ce qu'il y a un moyen de contourner le fait qu'il n'est pas possible de faire une recherche dans des rubriques statistiques ? Je les utilise souvent en affichage "Cases à cocher" pour faire un récapitulatif sur un modèle de plusieurs fiches liées à une table : J'ai une table "sites" qui affiche à chaque fois un site archéologique, et une table "subsite" qui affiche les différentes phases d'occupation d'un site. Donc relation de 1 à n. J'ai des rubriques de cases à cocher sur les enregistrements de "subsite" pour renseigner par exemple quel est le type de matériel qu'on a trouvé (militaire, domestique, minier, etc.) et le récapitulatif s'affiche sur l'enregistrement de "site", afin de voir de manière globale quel est le type de matériel trouvé, toutes phases confondues. Les utilisateurs de la table voudraient du coup pouvoir faire des recherches de type "dans quels sites a-t-on, toutes phases confondues, à la fois du matériel militaire et minier ?" Mais comme c'est une rubrique statistique, ce n'est pas possible ... Merci d'avance ! P.S. : j'espère être claire, j'ai souvent du mal à m'exprimer clairement sans envoyer la base entière pour illustrer mon propos, mais comme elle pèse déjà lourd ...
  4. Merci beaucoup à tous !!! J'ai bêtement oublié de cocher la case pour suivre le sujet, je n'avais pas vu que vous aviez répondu ! Je m'en vais tester de suite, Mille mercis !
  5. Super, merci beaucoup ! Désolée pour le délai de réponse, c'est le problème si je lis directement dans mes mails sans me connecter réellement au forum ...
  6. Rebonjour ! Je pense avoir trouvé une solution qui est un peu de la bidouille, mais qui devrait fonctionner: j'ai créé autant de modèles que j'ai d'occurrences de tables. les modèles sont identiques au niveau de la présentation, ce qui fait qu'on ne se rend pas compte dans quel modèle on est si on ne regarde pas son nom dans la barre d'outils. j'ai créé un panneau à onglet, avec un onglet pour chaque table que je veux pouvoir lier (Stratigraphical Unit, Room, Building et Site). Par-dessus chaque onglet, j'ai configuré un bouton déclenchant un script, qui active le modèle correspondant à la table (pour Stratigraphical Unit, le modèle Graphic Documentation, pour Room Graphic Documentation 4, pour Building, Graphic Documentation 3, pour Site, Graphic Documentation 2). Du coup les données ne sont pas visibles en même temps, mais elles sont au moins accessibles et modifiable au niveau de la photo directement. Si quelqu'un parmi vous a une meilleure solution, je suis preneuse, sinon je resterai avec ça
  7. Bonjour ! J'ai encore une question, cette fois-ci concernant l'import ou la récupération de métadonnées de photos que j'importe dans ma base de données. J'ai découvert comment récupérer de manière automatique un certain nombre de métadonnées d'une photo stockée dans une rubrique conteneur (via ObtenirAttributConteneur) et à les afficher dans des rubriques dédiées (le nom du fichier, sa taille, le modèle d'appareil photo, etc) mais je n'arrive pas à récupérer les tags que j'ai au préalable attribués à ladite photo, ni son format (jpeg, tiff, ...). Est-ce que quelqu'un ici connaît une astuce pour récupérer ces données automatiquement ? je devrai de toute manière créer des tags directement dans les métadonnées de centaines de photos que j'importerai dans la base de données d'un chantier de fouilles archéologiques, et si c'est possible, j'aimerais bien m'épargner de devoir faire le boulot deux fois en copiant manuellement les tags des métadonnées dans une rubrique "tags" de la base, idem pour le format du ficher (je peux créer une liste de valeurs et la renseigner, mais tant qu'à faire ...). Merci d'avance !
  8. J'ai tenté de réduire la taille au max de la base en supprimant la moitié des tables, mais elle fait encore 6,5 Mo donc je la mets via GrosFichiers : grosfi.ch/PBta7cGDdp2 J'ai bien sûr des identifiants pour chaque table (à part les tables jointes). J'espère que ça sera plus clair avec la base elle-même ... c'est sur le modèle T201 que j'aimerais pouvoir afficher les tables externes de T003 et T004, de même que je voudrais afficher sur T003 des tables externes de plusieurs occurrences de T904 (visibles au niveau de l'affichage des liens).
  9. Bonjour ! J'ai un problème récurrent dans la base de données que je crée en ce moment : Je voudrais pouvoir afficher sur un modèle des tables externes qui sont basées sur deux (ou plus) occurrences d'une même table. Illustration de mon problème : j'ai une table dans laquelle je veux répertorier toutes les photos qui ont été prises d'un site archéologique ("Graphical Documentation"). J'ai une table "Stratigraphical Unit", qui enregistre toute la documentation liée à un secteur de fouille archéologique précis. Ces Secteurs sont regroupés en "Rooms", pour lesquels j'ai également une table. Stratigraphical Unit et Room sont liés entre eux. Comme je veux avoir les photos des Rooms qui s'affichent dans une table externe sur le modèle de Rooms, j'ai créé une table jointe qui relie Rooms à Graphical Documentation. Pour faire la même chose avec Stratigraphical Unit, j'ai dû créer une seconde occurence de Graphical Documentation, liée à Stratigraphical Unit par une table jointe. J'aimerais pouvoir afficher les deux tables jointes sur le modèle "Graphical documentation", mais je n'y arrive pas, car une table jointe est liée à l'occurrence Graphical documentation, et l'autre table jointe est liée à Graphical Documentation 2, et que le modèle requiert une table de départ et non deux ... Est-ce qu'il y a un moyen de contourner ce problème ? (j'envoie volontiers ma base mais elle est assez lourde ...) Merci d'avance
  10. Ca explique pourquoi il y a un problème : le tri est donc impossible sur des valeurs homonymes. Du coup on va les différencier en précisant les noms, histoire de ne pas avoir de "doublons". Merci beaucoup !
  11. Voilà la version actuelle, les tables et modèles concernés sont SITES (à l'intérieur du modèle sites, voir l'onglet toponymy et documentation, où se situent les deux tables externes renseignées), MAPS et TOPONYMS. Navigation rapide grâce au popover Menu/Chameau en haut à droite de chaque modèle. Le nom d'utilisateur est Admin (sans mot de passe), j'ai supprimé les autres comptes pour vous l'envoyer. La base faisant 15Mo depuis que nous avons importé les données depuis excel, je l'ai uploadée par WeTransfer: https://we.tl/t-SHQ3XSFHQN merci beaucoup !
  12. Merci de votre réponse ! Il y a le même nombre de lignes dans le fichier excel que d'enregistrements dans FMP, aucune fiche vide, et dans la table intermédiaire, tout est renseigné ... c'est ça qui m'intrigue aussi, j'ai pensé à un problème d'importation, mais non, tous les ID sont là ! et j'ai également pensé à un problème Unicode puisque de nombreux noms contiennent des caractères non usuels, mais un même nom s'affiche correctement dans la fiche dédié et pas du tout dans la table externe, voire il s'affiche correctement sur une fiche et pas du tout sur une autre .... mais le lien est là vu que c'est l'ID qui s'affiche ...
  13. Bonjour, J'ai un problème tout récent dans la base de données que je construis depuis des mois, et qui se présente au moment où je teste l'importation de fichiers excel pour remplir la base. J'ai d'abord importé les enregistrements de la table SITES, puis les enregistrements de la table TOPONYMES, et enfin ceux de la table jointe, où se situent les liens entre les différents sites et les toponymes. Tout s'est déroulé de manière absolument parfaite, et tous les liens sont opérationnels, mais ... Pour certains enregistrements, sur le modèle des SITES, dans le menu local (avec liste de valeur à deux rubriques - l'ID et le nom du TOPONYME - dont seul le nom s'affiche) où la table externe m'affiche les différents TOPONYMES liés, les noms qui sont homonymes avec d'autres toponymes ne s'affichent pas, seul l'ID s'affiche. Par exemple, le toponyme TOP0455 a le même nom que le TOP0365. Au lieu d'afficher Wadi Al-Natrun, il affichera TOP0455. J'ai vérifié partout, pour voir si toutes les informations étaient bien remplies, j'ai tenté de changer de police d'écriture (il y a des signes diacritiques, qui apparaissent correctement d'ailleurs), rien à faire. Si je décoche la case de formatage des données, cela reste pareil, et si je ne demande pas à n'afficher que la deuxième colonne (c'est à dire le nom) dans la case, pour tous les enregistrements non problématiques, l'ID et le nom s'affichent, mais pour ceux qui posent problème, seul l'ID s'affiche. Est-ce un bug ? Est-ce qu'il y a une raison pour laquelle les homonymes ne peuvent pas être gérés ? je fais exprès le lien partout dans la base avec les ID pour être sûre qu'il n'y ait aucun problème de concordance, du coup je suis assez perplexe ! Merci d'avance à qui pourra m'aider ...
  14. Bonjour ! Je reviens par ici pour un problème que je n'arrive pas à résoudre ... je travaille toujours sur la même base de données archéologique. Dans cette base, il y a pour mon problème deux tables qui sont concernées: la table "sites" et la table "phases archéologiques". La table "sites" contient les sites archéologiques qui sont étudiés. La table "phases archéologiques" contient les différentes phases archéologiques des sites. La relation entre les deux tables est de 1 à N. Chaque site archéologique ayant au minimum une phase archéologique qui lui est liée. Une phase archéologique ne peut appartenir qu'à un seul site. Sur le modèle "phases archéologiques", on trouve beaucoup d'informations, qui concernent le site mais à une phase spécifique, et qui donc changent d'une phase à l'autre. Par exemple, une rubrique (cases à cocher) détaille la flore trouvée durant la phase. Les archéologues qui vont utiliser la base veulent, pour chaque site, avoir un récapitulatif des phases archéologiques, dans lequel on trouvera par exemple la flore trouvée sur le site, toutes phases confondues. Le but est au final d'avoir une phase globale par site (nombre de phases globales = nombre de site, et non nombre de phases) et de pouvoir faire des recherches (par exemple, sur quel site on trouve du blé, toutes phases confondues). J'ai tenté de créer des rubriques statistiques, ou de faire un rapport, mais j'avoue qu'ici je suis paumée, car à chaque fois je me retrouve avec un nombre de fiche égal au nombre de phases et non au nombre de sites ... Je tente également de faire démarrer mon modèle par la table Sites, et d'afficher les rubriques statistiques de la table Phases archéologiques. Mais je ne sais pas si c'est de la bidouille ou si c'est une solution viable. Est-ce que quelqu'un aurait sinon une idée de comment atteindre mon but ?
  15. Super, merci pour ces explications !
×
×
  • Create New...