Jump to content

NoémiV

Membres
  • Content Count

    37
  • Joined

  • Last visited

About NoémiV

  • Rank
    25
  • Birthday 09/20/1981

Profile Information

  • Gender
    Femme
  • Location
    Basel, Suisse
  • Interests
    Egyptology, Archaeology

FileMaker Profile

  • FM
    FMP18A
  • OS
    OSX10.14
  • Certification
    --Non certifié--
  • FBA
    --Non membre--

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. A ce que je vois c'est exactement ce que j'aimerais faire. Merci beaucoup !
  2. Merci ! j'avoue que je galère un peu, je découvre grâce à vous les rubriques multivaluées, mais je ne comprends pas encore comment je peux les intégrer dans une table externe de manière efficace. Merci également ! Mais ce que je ne comprends pas, c'est comment faire pour appliquer votre formule, car le nombre n d'enregistrements liés est différent pour chaque enregistrement ... du coup je ne vois pas où je pourrais insérer une formule qui calcule ça tout seul ...
  3. Merci beaucoup pour ta réponse et pour avoir répondu si rapidement ! Je vais voir ça avec les utilisateurs de la base ...
  4. Bonjour ! Je reviens par ici après Feedback des utilisateurs de la base de données : ils ne voient aucune information s'afficher dans les rubriques des SITES alors qu'ils ont introduit des informations dans les SUBSITES. Du coup j'ai checké de mon côté, et chez moi, tout fonctionne parfaitement. J'ai donc cherché du côté de la version de FMP qu'ils utilisent car j'ai déjà eu quelques adaptations à faire de ce côté-là. Ils sont sur FMP15. Or, la fonction "uniquevalues" a été introduite à partir de FMP16. Est-ce que cela signifie que leur version ne reconnaît pas cette fonction et que par conséquent cela ne peut pas fonctionner pour eux ? Si c'est le cas, y a-t-il un moyen d'ajouter cette fonction chez eux? Merci d'avance !
  5. Ca m'a l'air super aussi ! Bonne journée, Jérémie, et merci !
  6. Bonjour ! je suis en train de finaliser une base de données pour une équipe de fouilles archéologiques. Le but est de récolter toutes les informations liées à la fouille, c'est-à-dire des unités stratigraphiques fouillées jusqu'au matériel qui en est sorti. Pour stocker le matériel multimédia lié à chaque "département" de la fouille, j'ai créé des tables "graphic documentation". Une pour l'archéologie à proprement parler (unités stratigraphiques et les pièces / bâtiments auxquelles elles appartiennent), et une pour chaque type de matériel qui sort de la fouille (céramique, ostraca, objets, ...). Sur les modèles principaux, j'ai une table externe qui affiche le matériel multimédia lié. Maintenant, on me demande d'afficher tout le matériel multimédia sous forme de grille (vignettes) plutôt que sous forme linéaire (affichage classique des tables externes). Et là, je sèche. j'ai parcouru le forum mais les réponses sont toutes anciennes. La base est pour le moment uniquement dans mon ordinateur, mais à terme elle sera sur serveur (Huma-Num pour ceux qui connaissent), donc accessible à partir de plusieurs version de FileMaker (FMP15+). Est-ce qu'il existe une solution ? je n'ai pas besoin de faire apparaître autre chose que la rubrique conteneur, aucun titre ni quoi que ce soit, mais il faudrait pouvoir cliquer sur la photo ou un bouton lié à la photo pour pouvoir aller sur la fiche de ladite photo. Merci d'avance ! EDIT : j'ai trouvé ça https://www.scoop.it/topic/learning-filemaker/p/4060115278/2016/02/22/filemaker-pro-image-grid-youtube-53-53, qui au niveau de l'affichage correspond plus ou moins à ce que je voudrais, mais comme je voudrais plutôt une grille de 16 images et que je dois faire apparaître une grille sur 5 modèles différents au moins, j'apprécierais d'avoir une solution plus simple ...
  7. Ca y est, j'ai réussi, et j'en ai profité pour lier le bouton de statut à un script qui envoie un e-mail soit à moi soit à mes interlocutrices selon qui doit voir le dernier commentaire fait sur un ticket, comme ça plus besoin d'aller dans la base tous les jours pour vérifier si quelqu'un m'a écrit !
  8. C'est vraiment génial, merci beaucoup ! je vais tenter de comprendre avant d'appliquer, je m'endormirai moins bête ce soir !
  9. Merci beaucoup pour vos réponses ! Alors je vais continuer à chercher une solution, suis sûre maintenant que ça peut marcher donc je vais trouver Jérémie, j'ai modifié ton ticket de sorte à avoir une rubrique de titre en plus, comme ça je peux trier les sujets. Je pense que je vais également ajouter une option pour dire que le ticket est en cours de résolution, car cela arrive régulièrement. Je suis vraiment contente que tu m'aies fait profiter de ce ticket, c'est une excellente idée ! Merci
  10. Merci pour ta réponse ! En fait, le format doit rester en texte, car le début de la rubrique comporte une année, mais pour éviter les doublons la liste ressemble à ca : -1550/-1526 (Ahmose) -1525/-1501 (Ahmose) -1525/-1501 (Amenhotep I) -1525/-1501 ... Du coup, je ne peux pas passer la rubrique en nombre ... Sachant que j'ai deux autres rubriques, cette fois-ci en nombre, la première avec uniquement la date de début (-1550, -1525, ...) et la seconde avec la date de fin (-1526, -1501, ...). Mais j'ai impérativement besoin que la liste qui est utilisée pour lier ma table chronologique avec d'autres tables comporte les noms des souverains ... Je fais afficher ma liste en menu local, elle est basée sur un identifiant (CHYxxxxxx) mais affiche uniquement les valeurs de la rubrique dont j'ai montré des exemples ci-dessus ...
  11. Bonjour ! J'ai une question, car j'ai utilisé la méthode unicode pour trier une liste de valeurs, liée sur des dates (des années, de -1500 à 700). Le tri fonctionne bien en apparence, mais quand je veux afficher la liste dans une rubrique (configurée en menu local), j'ai uniquement les 109 premiers enregistrements qui s'affichent, le reste est complètement ignoré (j'ai 322 enregistrements en tout) ... Est-ce qu'il y a une quantité limitée de caractères invisibles que l'on peut insérer ? Merci d'avance
  12. Bonjour ! La base de données à laquelle je travaille depuis des mois est enfin en fonction, merci beaucoup à tous ceux qui m'ont aidée J'ai une dernière petite question à son sujet : Jérémie m'avait très gentiment donné un module de tickets de développement, dans lequel les utilisateurs peuvent me faire part de leurs suggestions d'amélioration, d'éventuels problèmes ainsi que de remarques. Je précise que la base de données a été mise en ligne sur un serveur spécial (Huma-Num pour ceux qui connaissent), et qu'elle est accessible donc via hôte ou en Webdirect. J'apprécierais beaucoup qu'à chaque fois que quelqu'un crée un ticket, je reçoive une notification (je suppose par e-mail, mais je suis ouverte) pour me prévenir que je dois aller sur la base, sachant que je ne suis moi-même pas une utilisatrice de cette base. J'ai donc cherché à intégrer une ligne dans le script que Jérémie avait fait pour créer un nouveau ticket, mais je n'ai soit pas eu de résultat, soit fait planter la base (obligation de redémarrer l'application). J'en ai donc conclu que la fonction "courrier" n'était pas prévue pour les envois automatiques ... Est-ce que quelqu'un aurait une idée ? Mon but est vraiment que les utilisateurs n'aient rien à faire et que tout se fasse en arrière plan. Sinon, ils peuvent m'envoyer un e-mail directement, ce qui n'a à nos yeux aucun sens car nous voulons partager les questions et résolutions avec tous les utilisateurs et en garder une trace dans la base ... Merci d'avance ! Noémi
  13. Merci de cette réponse rapide ! Donc si je comprends bien, pour avoir le résultat "archaeological site" et uniquement celui-là, je dois faire la recherche non pas dans un jeu de cases à cocher mais dans un champ libre ... je pourrais en effet faire un script pour cette liste de valeurs. Et voir à quelle fréquence ce genre de problème peut survenir ... Merci beaucoup !
  14. Bonjour ! Je suis tombée sur un os dans ma base de données de sites du désert égyptien : j'ai un grand nombre de listes de valeurs basées sur des listes personnalisées. Le but de la base étant de pouvoir faire beaucoup de recherches et de recherches croisées, il faut impérativement qu'il soit possible d'activer des recherches sur la base de ces listes de valeurs. Une d'entre elles détermine le type de site répertorié (archaeological site, non archaeological site, watering place). Or, quand je recherche tous les "archaeological site" en cochant la case correspondante en mode recherche, le résultat de la recherche me donne tous les archaeological sites, ce qui est très bien, mais également tous les non archaeological sites, ce qui l'est beaucoup moins (voir captures d'écran). Je peux bien imaginer que le problème réside dans le fait que dans "Non archaeological site" il y a "archaeological site", mais 1) je ne comprends pas pourquoi (et m'insurge que) cela pose problème dans une liste de valeurs (la recherche s'effectuant d'après la liste de valeurs elle-même et non en champ libre et 2) cela m'embête beaucoup car je dois absolument trouver une solution ... Est-ce que quelqu'un aurait une solution viable qui ne m'oblige ni à changer drastiquement toutes mes listes ni à mettre des numéros où je ne sais quoi de très peu esthétique ?
  15. C'est génial, exactement ce dont j'avais besoin, et en plus j'ai appris quelque chose de nouveau merci beaucoup !!!!
×
×
  • Create New...