Jump to content

ENVERGURE

Membres
  • Content Count

    33
  • Joined

  • Last visited

About ENVERGURE

  • Rank
    25

Profile Information

  • Gender
    Homme
  • Location
    Pas-de-Calais

FileMaker Profile

  • FM
    FMP 13 Advanced
  • OS
    Mac
  • Certification
    --Non certifié--
  • FBA
    --Non membre--

Recent Profile Visitors

2219 profile views
  1. Bonjour ! j'ai créé une base de donnée qui gère la correspondance, et génère notamment nos e-mails. Concrètement, on rempli quelques champs pour rédiger le message et choisir le destinataire via une liste. Puis, FM se charge du reste, et crée l'e-mail directement dans Outlook, avec titre, formules de politesses et autres, grâce à la fonction "Envoyer courrier […] >> via client de messagerie électronique + créer un courrier électronique utilisant les données de l'enregistrement actuel". Iil n'y a plus qu'à relire et appuyer sur "envoi"' et "Paf ! le mail !" PROBLÈME - ça marche très bien sur le Mac, sur FileMaker et en WebDirect (avec Safari, Chrome ou Firefox). - Par contre, sur Windows en WebDirect, le script ne génère pas le mail (ni avec Chrome ni avec Firefox) >> on est donc obligé de faire la manipulation sur FMPRO >> on est donc "dépendant" du PC sur lequel est installé FMPRO, et on ne peut pas générer un mail à distance via la base (sous WebDirect, donc). Ce qui nous gène pour le télétravail. - j'ai bien vu qu'il y a une option pour passer directement via le serveur SMTP, mais ça n'est pas super pratique, car, une fois envoyé, il n'apparaît pas dans la liste d'Outlook des mails envoyés (puisque l'on ne passe pas par Outlook). Or, on a besoin de garder la trace juridique des envois de mails, et Outlook reste l'outil le plus fiable pour ça … QUESTION y a-t-il un paramètre que j'aurais omis d'activer pour que Chrome/Firefox laisse WebDirect télécharger le mail généré vers Outlook ? (comme c'est le cas sur Mac) merci à tous pour votre aide ! Fabien
  2. Bonsoir David ! Merci beaucoup pour ton aide ! Je ne cherchais donc pas au bon endroit … (et on a cherché longtemps - depuis 3 jours ! ça rend fou !) Je vais enfin pouvoir régler ça en retournant au bureau demain matin, alors !😃
  3. Bonjour à tous ! J'ai développé une base de donnée pour faire des diagnostics techniques. Elle est accessible sur Filemaker GO. Nous avons besoin de faire des photos. Pour cela, j'ai programmé un script qui utilise la fonction : insérer depuis appareil [ rubrique cible ; type : app. photo ; App. photo : Arrière ; Résolution : "moyenne"] ON A ACHETÉ UN NOUVEL IPAD Pour faciliter le travail sur le terrain, on a acheté un nouvel iPad (plus confortable pour nous) … et installé Filemaker Go 16, 17 et 18 dessus (les 3 versions). L'OS de l'iPad a été mis à jour avant. PROBLÈME Lorsque l'on utilise l'application sur Filemaker Go 16, 17 sur 18, l'application accède bien à l'appareil photo de nos iPhones … mais jamais à celui de l'iPad ! Sur iPhone, FM GO demande bien l'autorisation d'accéder à l'appareil photo, mais pas sur l'iPad, quelle que soit la version de FMGO utilisée (on a essayé avec les 3). Pourtant, le script est le même, et la fonction "insérer depuis appareil [ ... ]" ne présente pas d'option particulière selon que l'on opère sur iPhone ou iPad. Je suis allé voir dans les réglages : - sur l'iPhone, les autorisations d'accès à l'appareil photo pour Filemaker 16 sont bien activées. Elles n'apparaissent pas pour Filemaker 17 et 18. - Sur l'iPad, il n'y a rien (que SIRI), quelle que soit la version (16, 17 ou 18) En pièce jointe, les photos de nos écrans. QUESTION Sauriez-vous comment régler ce fâcheux pépin d'accès à l'appareil photo sur l'iPad ? C'est très handicapant pour nous. merci beaucoup pour votre aide !
  4. Bonjour ! Ah ! Magnifique ! Merci beaucoup ! Je vais rechercher ça dans la V16 pour une mise à jour éventuelle. bonne semaine cordialement Fabien
  5. Bonjour à tous, CONTEXTE J'ai développé une base à plusieurs fichiers, qui partagent des liens, infos …etc. Elle est hébergée sur un serveur FMServer, et accessible à distance via FMpro ou en Webdirect via un navigateur. Pour travailler, on a besoin de naviguer entre les fichiers, et de les ouvrir parfois à plusieurs en même temps ("en cascade", disons). SÉCURITÉ j'utilise le mode de connexion à la base via des login+pass MS Azure (bouton s'identifier via "microsoft" quand vous ouvrez un fichier). PROBLÈME SUR FMPRO, pour passer d'un fichier à l'autre, j'utilise la fonction "activer l'enregistrement lié" (depuis le fichier A) et "ouvrir une nouvelle fenêtre" (pour travailler sur le fichier B entre temps). Une fois le travail effectué sur le fichier B (dans la nouvelle fenêtre), j'ai un bouton qui referme la fenêtre, et on continue à travailler sur le fichier A. Ça marche très bien sur FMPRO, naturellement. EN WEBDIRECT : tout s'affiche uniquement sur le même onglet / dans la même fenêtre, et le bouton/ la fonction "fermer la fenêtre" ne fonctionne pas dans ce cas (pour fermer le fichier B et revenir au fichier A). Lorsque l'on veut refermer/quitter le fichier B, on est obligé de se déconnecter complètement, pour se reconnecter ensuite au fichier A, et reprendre le travail >> fastidieux, comme vous pouvez vous en douter. QUESTION existe-t-il un moyen de détecter si un utilisateur se connecte en Webdirect sur une base hébergée sur FM serveur ? Auquel cas, je peux avoir un "script d'aiguillage" qui gère tantôt la fermeture d'une fenêtre sur FMpro, tantôt la navigation sur Webdirect, ce qui nous éviterait de devoir revenir au point de départ à chaque fois. PISTE J'ai cherché dans les fonction "Obtenir(xxxx)". Je sais identifier avec quel type d'appareil un utilisateur se connecte (iPad, iPhone, ordinateur de bureau), mais pas s'il passe par FMpro ou en Webdirect. Merci pour votre aide précieuse !
  6. Bonjour Philippe ! Magnifique !!! C'est exactement ce que je voulais faire ! (FMsource, c'est mieux que la télépathie ! 😉). merci beaucoup pour ce précieux coup de main. J'ai en même temps appris beaucoup de choses sur la structuration d'une base, et sur les globales (que je ne maîtrise pas encore, mais que je commence à comprendre un peu mieux grâce à vous). Il me reste à continuer le développement pour déployer ça sur FMserver et la rendre accessible via Internet et sur des tablettes et smartphones. Cet outil va nous aider beaucoup ! mille merci ! bonne semaine, bonnes vacances éventuellement cordialement Fabien
  7. Bonjour Philippe Merci pour ce coup de main précieux. Je n’avais pas pensé le développement de cette façon et ça colle presque avec ce dont nous avons besoin. J’ai une amélioration à y apporter : quand on ajoute un corps d’état dans un logement (sur la table « LOGEMENT CHANTIER »), j’ai besoin que toutes les questions dudit corps d’état apparaissent d’un seul coup, pour que l’on n’ait plus qu’à y répondre (enregistrements de la table DIAGNOSTIC). La contrainte étant que si l’on ajoute une question dans un corps d’état en cours de route, elle apparaisse instantanément pour tous les logements (diagnostiqués ou à venir). Il n’y a plus alors qu’à y répondre (DIAGNOSTIC). IDÉE Pour vous montrer ce que j’ai essayé, dans le modèle « LOGEMENT détails questions », j’ai fait un panneau avec 2 onglets : 1 onglet avec votre solution, et 2 onglets avec les alternatives que j’essayes de mettre au point. CA MARCHE MAIS PAS COMPLÈTEMENT Lorsque l’on ajoute une question dans un corps d’état, elle apparaît bien pour tous les logements concernés (ce dont j’ai besoin). Il me reste juste à faire en sorte que je puisse incrémenter la table DIAGNOSTIC à partir de là (le champs « réponse » de la table DIAGNOSTIC en bleu). Pour le moment, lorsque je clique sur une coche (champs « réponse » de la table DIAGNOSTIC), la réponse est la même, soit pour toutes les questions (alternative 1) soit pour tous les logements (alternative 2). En fait, je ne sais pas sur quel lien jouer pour que créer le bon enregistrement dans DIAGNOSTIC à partir de la question affichée. Là, j’avoue que ça dépasse mes compétences (encore) … Si la solution existe, je suis preneur ! Un grand merci pour votre coup de main Fabien DIAGNOSTIC V3.fmp12
  8. Bonjour à tous Je dois réaliser le diagnostic technique de 300 maisons pour un bailleur social. Chaque maison a fait l’objet de travaux, mais pas les mêmes partout. Notre client a perdu la trace de ces travaux. Donc, pour chaque maison visitée, nous devons d’abord affecter des corps d’états (ex : gros œuvre, second œuvre, toiture …etc), puis vérifier un certains nombre de points techniques pour chaque corps d’état . D’un logement sur l’autre, on peut ne pas avoir les mêmes corps d’états à diagnostiquer : ex : LOGEMENT 1 : gros œuvre + toiture LOGEMENT 2 : gros œuvre + second œuvre LOGEMENT 3 : second œuvre …etc. J’ai créé une liste de questionnaires (corps d’états). Chaque questionnaire compte plusieurs questions. MAIS il se peut que notre client nous demande d’ajouter un point de contrôle en cours de route dans un ou plusieurs des questionnaires … Je dois donc pouvoir répondre aux questions pour chaque logement, et, au cas où il faille ajouter une question à un questionnaire, il faut qu’elle apparaisse instantanément pour tous les logements concernés, pour pouvoir y répondre ensuite pour chaque logement. PROBLEME J’ai donc créé 4 tables, avec des liaisons « n à n » … mais les réponses à un logement apparaissent sur un autre dès lors que j’affecte le même questionnaire aux 2 logements concernés. Naturellement, j’ai besoin d’une réponse « personnalisée » par logement pour chaque question des questionnaires affectés à un logement. Je vois bien qu’il y a un truc avec l’affichage d’une table externe, mais je ne parviens pas à trouver la solution. En pièce jointe, le fichier que je développe. Je m’arrache les cheveux sur ce projet : si quelqu’un sait m’aider, ça me permettrait de garder mes cheveux ! Merci d’avance ! Fabien DIAGNOSTIC V1.fmp12
  9. Hello ! je m'appelle Fabien (enchanté Jérémie !). Je n'ai pas encore pris le temps de me replonger dans mon fichier, priorités prioritaires à gérer dans mon travail. Je m'y attèle dès que possible. Merci à tous les 2 pour vos remarques. Je vais tenter une version V2 avec vos suggestions et reviens vers vous avec une nouvelle version. bon WE ! Fabien
  10. Bonjour à tous ! Je développe un outil de descriptif technique et d’analyse d’offres, qui me permet de comparer les prix de plusieurs entreprises, article par article. Voici comment ça marche : PROJET - on crée un ou plusieurs projets - pour chaque projet, on crée des LOTS. - chaque LOT est décrit par une arborescence comme suit : LOT >> PARAGRAPHE >> ARTICLES >> SOUS-ARTICLES - le prix de chaque sous-articles est « estimé » - la somme des sous-articles donne le coût total par lot, par projet …etc. ENTREPRISES - pour chaque projet, des entreprises répondent à un appel d’offre. - dans un appel d’offre, les entreprises peuvent répondre à 1 ou plusieurs lots. - pour chaque ENTREPRISE, on renseigne leurs PRIX pour chaque sous-article des lots auxquels elle a répondu. CE DONT J’AI BESOIN - après avoir affecté un ou plusieurs lots à chaque entreprise, j’ai besoin de renseigner les prix donnés par l’entreprise pour chaque sous-article (du/des lots auxquels elle a répondu). >> un sous-article peut donc avoir plusieurs prix d’entreprises. CE QUE J’AI FAIT - j’ai créé une table « PRIX », que l’on peut renseigner à partir du formulaire « ENTREPRISE prix ». - j’ai créé un script « ACTIONS » qui génère autant d’enregistrements « PRIX » qu’il n’y a de sous-articles dans tous les lots auxquels l’entreprise à répondu. PROBLÈME - je ne parviens pas à lier automatiquement le SOUS-ARTICLE à l’enregistrement « PRIX » ; pour cela il me faut connaître la clé pour les lier … or, il peut y avoir une centaine de sous-articles à renseigner >> ça devient vite fastidieux. CE QUE JE N’ARRIVE PAS À FAIRE - créer un script qui : 1. génère automatiquement le même nombre d’enregistrements dans PRIX que dans le LOT, en les affectant à ENTREPRISE 2. lie les SOUS-ARTICLES du LOT auquel l’ENTREPRISE répond, aux enregistrement vierges de la table PRIX OBJECTIF >> ainsi, il ne me restera plus qu’à renseigner le champs « OFFRE PRIX ENTREPRISE » de la table PRIX pour chaque ENTREPRISE PIÈCE JOINTE - un fichier FMPRO 16 qui montre où j’en suis. Merci pour votre aide précieuse ! BASE 01.fmp12
  11. ENVERGURE

    ENVERGURE

  12. bonsoir à vous deux merci pour vos réponses. Je n'ai pas pris le temps de relever vos réponses ces derniers temps (gestion des priorités prioritaires oblige). Je vais regarder ça et vous dirais la solution mise en œuvre. merci ! à bientôt !
  13. Bonsoir à tous, Nous avons changé de version FM PRO (passé de la 13 à la 16) sur Windows 10. Nous avions un outil pour générer des e-mails depuis FM PRO 13 et les envoyer via Outlook. Ca fonctionnait très bien. Sur FM PRO 16, ça plante : Outlook bloque et affiche un message disant : "Serveur occupé : impossible de terminer cette action car l'autre programme est occupé. Choisissez "basculer vers" pour activer le programme occupé et corriger le problème". Naturellement, quand on clique sur "basculer vers …" >> rien ne se passe. Impossible d'annuler ni de recommencer. Tout est figé. On est donc obligé de faire un "contrôle + alt + sup" et de redémarrer Outlook et FM PRO. J'utilise la commande "envoyer courrier [envoyer via client de messagerie ]". Je ne trouve pas la solution pour remédier à mon pb. Quelqu'un aurait-il déjà eu ça ? d'avance, merci pour votre aide !
  14. Hello ! Super ! Ca marche. Merci beaucoup ! Pour les jours de semaines 1 et 7, j'en avais déjà tenu compte, et la semaine 53, j'avais remarqué aussi (aussi bien sur FM PRO que sur EXCEL, d'ailleurs), sans en avoir l'explication "scientifique". Désormais, je comprends d'où ça vient, et vais pouvoir en tenir compte aussi. Pour mon profil FBA, je ne m'étais jamais rendu compte que j'étais "Membre Platinum Trainer & Reseller", et j'ai changé ça, naturellement. Je ne sais pas d'où ça sort, d'ailleurs … Je suis architecte, et ça me suffit, globalement, pour développer mes outils sur FM PRO lors de mes longues soirées d'hiver au coin du feu. Bon WE, bon pont/viaduc, et bonne fête du travail !
  15. Bonjour à tous, Je suis en train de mettre au point un planning de Gantt. Dans une rubrique multivaluée, j’utilise une formule pour afficher les numéros de semaines. Voici la formule : Multivaluee ( NUMERO SEMAINE date démarrage ) + Obtenir ( NombreRépétitionsCalcul ) RESULTAT J’obtiens une échelle qui s’incrémente à partir de la date de démarrage du planning. PROBLEME Lorsque le planning chevauche 2 années, l’incrémentation continue au-delà de 52, à l’infini … quand j’ai besoin qu’elle redémarre à 1. Quelqu’un sautait-il comment résoudre ce problème ? D’avance, merci beaucoup !
×
×
  • Create New...