Jump to content

FMROSS

Membres
  • Posts

    28
  • Joined

  • Last visited

Profile Information

  • Gender
    Homme
  • Location
    France

FileMaker Profile

  • FM
    FMP 19 Cloud
  • OS
    MAC OS Catalina
  • Certif.
    --Non certifié--
  • Claris Partner
    --Non membre--

Recent Profile Visitors

1222 profile views

FMROSS's Achievements

Newbie

Newbie (1/14)

1

Reputation

  1. Bonjour à tous, Quelqu'un sait-il comment récupérer le contenu d'un WebViewer lorsqu'on exécute l'appli en WebSerivce Je cherche l'équivalent de ObtenirAttributModèle("Webviewer";"Content") - Cette fonction renvoie une chaine vide en Webservice Merci
  2. Bonjour à tous, Je cherche actuellement une solution pour transmettre des données FMP vers Salesforce. Le tout fonctionne parfaitement sur l'ordi d'un collaborateur qui m'aide à développer mais pas sur le mien. Le problème suivant se présente "Origin null is not allowed by Access-Control-Allow-Origin." Il semblerait que cela vienne du niveau de sécurité du navigateur exécuté en Local. Je suis sur Chrome lui sur Edge. Certains d'entre vous auraient-ils rencontré et solutionné ce problème ? D'avance merci
  3. Bien aidé par vos contributions dans d'autres Topic et après des heures de recherches sur internet, j'ai trouvé comment créer un dossier, le déplacer, le renommer ! Petite victoire pour un débutant et autodidacte en programmation. Il me reste à trouver comment tester l'existence d'un dossier et avoir le retour d'information pour lancer un script si besoin ?
  4. Si je peux encore me permettre ☺️ dans mon script je vais aussi avoir besoin de déplacer un Dossier et ses sous-dossiers vers un nouvel emplacement et potentiellement renommer ce dossier C'est vraiment dommage que ces fonctions ne soient pas natives dans FMP, de plus j'aimerais éviter les plugIn car je me sens pas suffisamment expert pour corriger l'incident rapidement s'il devenait obsolète au gré des mises à jour FMP Hâte de vous lire Merci
  5. Je suis sur la piste avec la découverte du pas de script "Emettre évènement" et CMD MKDIR Je précise donc ma demande. L'idée est de créer des dossiers dans le dossier Dropbox local de l'utilisateur. Dans ma table utilisateur, je pensais ajouter une rubrique contenant le chemin vers le dossier Dropbox. Dans le cas ou cette rubrique serait vide, alors l'utilisateur serait invité à "montrer le chemin" une première fois pour renseigner la rubrique. Mais si ce chemin devait évoluer pour X raisons, j'aimerais que mon script vérifie systématiquement son existence. Pour cela, quelle commande exécuter, comment récupérer le résultat de cette vérification pour la traiter ?
  6. Bonjour, Lors de la création d'un nouveau projet par l'utilisateur, j'aimerais que cela déclenche automatiquement la création d'un dossier et ensemble de sous-dossiers sur son disque. J'ai déjà fait ça par le passé avec Apple Script, mais j'ai à présent des utilisateurs OS et WINDOWS D'avance merci pour les pistes proposées
  7. FMROSS

    API Google Maps

    Bonne piste, merci beaucoup je vais explorer ça maintenant que je suis plus à l’aise sur le sujet grâce à vous 😉
  8. FMROSS

    API Google Maps

    Oui déjà fait merci ! Le site google au sujet des API est plutôt imbuvable. Il semble que ce soit gratuit si ta consommation est inférieure à 200$/mois. Me concernant, je pense pas avoir une grosse consommation, si je pars sur le prix unitaire le plus défavorable, ça pose la limite à 20.000 sollicitations / mois, ça me semble énorme comme plafond... y a t-il une erreur de compréhension de ma part ?
  9. FMROSS

    API Google Maps

    Merci Clem, J'ai testé avec l'URL directement dans un WebViewer, et j'ai bien le retour, il me reste à explorer la récupération des informations...
  10. FMROSS

    API Google Maps

    Bonjour, Voilà deux jours que j'essaie de calculer une distance (métrique) et une durée (voiture), je parcours le forum mais les discussions sont anciennes. Je découvre le JSON et les API... et j'ai beaucoup de mal à faire mes débuts Dans l'idée, je partirai non pas d'adresses mais de coordonnées Longitude / Latitude Est-ce que vous pourriez m'indiquer le pas à pas pour y arriver. Pour le moment, j'ai mes rubriques de coordonnées Départ et Arrivée J'ai un WebViewer qui attend des instructions J'ai créé un API Distance Matrix. En fait je ne sais pas Comment rédiger une URL conforme (j'ai testé pas mal de choses glanées sur internet, mais ça ne fonctionne pas) Comment interpréter le résultat JSON D'avance merci pour votre aide
  11. Bonjour, je fais mes premiers pas en matière d'API. Je suis en bonne voie. Toutefois je ne vois pas ou exploiter ces lignes // pour la valeur distance JSONGetElement ( $variable ; "rows[0].elements[0].distance.value" ) // pour la valeur duration JSONGetElement ( $variable ; "rows[0].elements[0].duration.value" )
  12. Merci Christophe, J'avais fait pas mal de tests, créé des occurrences, des calculs... j'ai du m'y perdre mais tu as raison ça aurait du fonctionner. Je devais passer à côté d'une erreur évidente En tout cas, ce que tu m'as proposé, c'est exactement, ça. J'ai donc fait table rase de mes occurrences de tables... et suis reparti de zéro avec ton modèle... ça fonctionne. Merci pour ta réactivité, on trouve toujours de l'entraide ici 😉
  13. Bonjour à tous, Je ne parviens pas a faire la chose suivante. J'ai une table [Devis], classiquement chaque devis a un Numéro unique [ID_Devis]. J'ai une sous-table [Devis_Version] de sorte que chaque devis ait au moins une ou plusieurs version [Num_Version] Tous les devis ont un Statut "Publié" voire "Accepté" si validation du client Il arrive qu'un Devis pourtant accepté, fasse l'objet d'un Avenant ultérieurement, qui sera lui même "Accepté" ou restera au stade de "Publié" si le client ne donne pas suite Je cherche à créer une rubrique calculée qui m'indique si parmi les versions supérieures, l'une d'elle a été Acceptée dans le but final de pouvoir sortir un rapport des Versions acceptées les plus récentes et les facturer ensuite La piste que j'ai exploré mais qui ne fonctionne pas est la suivante : J'ai lié ma table [Devis_Version] à elle même, établi un lien "=" sur le "ID_Devis Lié" puis un lien sur le [Num_Version] avec l'opérateur ">" Déjà à ce stade, je n'obtiens pas la liste des versions supérieures à celle comparée ??? En suite, dans une rubrique calculée, mon objectif était d'utiliser la fonction Liste pour lister les statuts des versions supérieures trouvées puis la fonction Occurrences sur cette liste pour vérifier si l'une d'elle contient "Accepté". Dès lors je savais si une version supérieure avait été acceptée. Voilà une demi journée que je cherche où est le bug. En espérant être clair 🤪 Merci d'avance
  14. Bonjour, Pourriez vous m'éclairer au sujet du comportement des références externes lors de la duplication d'un enregistrement. Je la fait courte, dans une base qui me sert à faire des devis, j'ai une table [produits types] et une [table devis] dans laquelle l'utilisateur appelle un produit type via un code produit type, ainsi la description produit, le prix... sont récupérés dans le devis via ref. Externe. L'utilisateur pourra ensuite modifier le libellé ou le prix à sa guise. lorsque je veux dupliquer une ligne du devis, j'aimerais qu'elle soit dupliquée à l'identique mais parfois la ligne est mise à jour via la ref. externe et parfois pas. Du coup je perds les modifications apportées par l'utilisateur. Je fais d'abord une recherche de l'enregistrement à dupliquer puis je fais Dupliquer enregistrement / Requête ; à aucun moment je viens modifier le contenu d'une rubrique qui pourrait provoquer une mise à jour de la ref. externe Help !
  15. Non effectivement le modèle totalement vide ne plante pas. J'ai suivi ton conseil, j'ai remis les objets un à un... et jusqu'au dernier aucun Bug, ça fonctionne ! Ca semble tellement simple que je me demande comment j'ai pu chercher aussi longtemps. Mais ça reste un mystère total. Où était le problème ? J'avais testé un nombre incroyable de solutions certaines très proche de cette solution ; mais pas celle là... en plein de le mille Jacques ! 🎯 Merci. 🙏 Pour mémoire : 1- J'ai dupliqué mon modèle pour en garder une copie avec tous les objets. 2 - J'ai supprimé absolument tous les objets du modèle initial (y compris désactivation des déclencheurs de script) 3 - J'ai re-copié collé un à un les objets depuis le modèle clône vers le modèle initial (en testant à chaque insertion l'activation du modèle). Les objets sont donc rigoureusement identiques, seule différence leur position dans le modèle peut-être, mais lorsque je les mettais de côté dans une zone non affichée du modèle le Bug subsistait. Mystérieux !!! Reste à voir dans la durée
×
×
  • Create New...